Recolor mesh problem with lenght of the results

I am trying to obtain the daylight factor diagram using RECOLOR MESH.
I am developing a script that it is possible to change the number of buildings and its dimensions and number of floors. But in the part to evaluate DF, I am having this warning:

  1. length of the results [=120] is not equal to the number of mesh faces [=4] or mesh vertices[=9].

This is because I have 120 test points but for some reason I can’t have the same value for mesh vertices. I tried flattening the meshes but still didn’t work.
I see that some topics already discussed about this matter but I couldn’t really find a solution for mine.
I send the file here, any help is appreciated. I circled in red the part of DF.
Thank you!!

Radiation analysis (817.5 KB)

@rafaellabmonteiro The result of daylight factor is 30 zone. You just conntect one zone to input mesh. The two did not match. If you want to show one zone of 3o zone, you should graft the test point.

Here is fixed grasshopper file for you.
daylight (822.1 KB)

1 Like

Thanks a lot @minggangyin!!! :grinning:

Hi. I did not understand how you changed the setting. I have the same problem and don’t know how to solve it.

Hi @simsim.
Your model has two branch data and mesh. You should join the meshes and flattern data to one branch. (776.4 KB)
could you please tell me where i have to do this?

Here is one demo for my workflow, you can refer to it.
combine multi plane (615.7 KB)


Thank you for your help. jion mesh was the answer