Recolormesh doesn't create gradient colour but one colour and "no light source" message appears

I have three problems here:

1-first problem: (recolormesh) component NO.1 doesn’t create any colour as shown in Fig A. and i think because the message of (the file is used in another process) as shown in fig 1.
I tried to delete annual simulation folder from this path C:\ladybug\unnamed\annualSimulation but I can’t because it tells me that this folder used in another program as shown in fig 2.
I want to know how can I delete annual simulation folder?

2-second problem: this message from (recolormesh) component NO.2 appear (1. length of the results [=1] is not equal to the number of mesh faces [=462].).
but when I tried to type this character (~) at RadFileName, the problem disappeared and recolormesh creats colors. i want to know why this happened, and am i must write this same character (~) at RadFileName every time?
i want to know why this messeage appeare?

3-i dont know why (recolormesh) component doest create gradient colour but one colour on the ground of cube as shown in fig 3. i think this problem appears because this message appears (there is no light source) in fig 1. and I don’t know why there is no light source? (624.2 KB)

@Aalaausama For Q1, because the annual simulation folder is using by Rhino. If you want to del it , you should close Rhino App.

For Q2: the rad name does not effect the result

For Q3: You use the legendpar to show the lux between 0 and 10 . It is a very low lux. I just disconnect the legendpar, the result showed nice .

but why wires are coloured with orange?

you can turn off the preview of brep