RecursionError in annual daylight calculation HB 1.7.0

Hi everyone,

I also have a RecursionError for annual daylight calculation in Honeybee v1.7.0.

It is linked to the size of the grid.
If I enter a grid size of 0.5 m the simulation works perfectly but if I enter a grid size of 0.05m I have the RecurionError.

I have 5 grids with the following areas :

  • 2190 m2
  • 1039 m2
  • 355 m2
  • 151 m2
  • 129 m2

Is it because I reached a grid points limit ?

I tried the LB versioner but I still have the problem.

You can find my Grasshopper file on the link below

Have a nice day !

There is no such a limit in Ladybug Tools. Can you share the logs from your run?

Hi @mostapha ,

Thanks for your reactivity !

You can find the link below :

Is it what you excepted ?

Have a good day,

1 Like

Yes. These are the files that I was looking for. Thank you for sharing them. Here is where the error happens:

2023-12-19 15:42:09 ERROR: "RestructureDirectSunlightResults" failed. See below for more information:

    OSError: 347833224 requested and 0 written

2023-12-19 15:42:09 ERROR: [pid 11188] Worker Worker(salt=4679887990, workers=15, host=WP-PC-067-PK, username=wrap, pid=86696) failed    RestructureDirectSunlightResults(_input_params={"bsdf_folder": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/model/bsdf", "direct_sky": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/sky_direct.mtx", "identifier": "default", "light_path": "__static_apertures__", "octree_file": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/dynamic/octree/default.oct", "octree_file_direct": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/dynamic/octree/default_direct.oct", "octree_file_with_suns": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/dynamic/octree/default_direct_sun.oct", "params_folder": "__params", "radiance_parameters": "-aa 0.1 -ab 10 -ad 4096 -ar 256 -as 1024 -dc 1.0 -dj 1.0 -dp 512 -dr 6 -ds 0.02 -dt 0 -lr 16 -lw 0.0001 -ss 1.0 -st 0", "results_folder": "../../../results", "sensor_grids_folder": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/dynamic/grid/__static_apertures__", "sensor_grids_info": [{"name": "0", "identifier": "0", "full_id": "0", "group": "", "count": 30610}, {"name": "1", "identifier": "1", "full_id": "1", "group": "", "count": 30610}, {"name": "2", "identifier": "2", "full_id": "2", "group": "", "count": 30610}, {"name": "3", "identifier": "3", "full_id": "3", "group": "", "count": 30610}, {"name": "4", "identifier": "4", "full_id": "4", "group": "", "count": 30612}], "simulation_folder": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/calcs/2_phase/default", "sky_dome": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/sky.dome", "sun_modifiers": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/suns.mod", "total_sky": "D:/GG/Ladybug/LadybugSim/24063 Olympus/TranspS0.5_2/DA/Floor/OtherRooms/annual_daylight_enhanced/resources/sky.mtx"})
Traceback (most recent call last):
  File "C:\Program Files\ladybug_tools\python\lib\site-packages\luigi\", line 203, in run
    new_deps = self._run_get_new_deps()
  File "C:\Program Files\ladybug_tools\python\lib\site-packages\luigi\", line 138, in _run_get_new_deps
    task_gen =
  File "C:\Program Files\ladybug_tools\python\lib\site-packages\queenbee_local\", line 369, in run
    raise ValueError(err_msg)
ValueError: "RestructureDirectSunlightResults" failed. See below for more information:

    OSError: 347833224 requested and 0 written

It looks like you don’t have enough space in your drive. When you create a smaller grid Honeybee needs more space in your hard drive and it fails because it is not available.

1 Like

Hi Mostapha,

Sorry for the late answer but I was in holidays.

Thanks a lot for your feedback. It works now ! Wonderful !

Have a nice day !