RecursionError in radiance recipe execution

One of my students is having an issue where the Radiance recipe components (HB Annual Daylight, HB Annual Radiation, etc.) are failing to generate results. An “invalid result folder” error is reported in Grasshopper, but this appears to be a symptom of a larger problem that prevents the results folder from being created in the first place.

The console window that appears when the simulation is run shows a RecursionError taking place in the _get_log_folder method of QueenbeeTask. The short-lived nature of these windows has made it difficult to glean any other information.

Any idea what might be going wrong?

Hi @coditect, This happens if you use the latest version of queenbee-local or lbt-recipes to run an older version of the recipe. I added better logging to queenbee-local and this command is looking to find the log file which gets generated with each recipe. If you update everything to the latest version it should all work as expected. I believe @chris has already resolved this issue in the latest version.

1 Like

Yes, your student must have been one of the lucky few who ran the Versioner component right in the window of the few hours that this bug was in the development version. As Mostapha says, it’s fixed in the latest development version now.

Excuse me @mostapha,

I would like to ask about update everything to the latest version. What do you mean here about everything? I face the same issue when I run the annual daylight simulation.

Thank you very much and look forward to your reply.

Best regards,

Clarence Wang

Hi @Clarence! Try using LB Versioner component.

Hi everyone,

I also have a RecursionError for annual daylight calculation in Honeybee v1.7.0.

It is linked to the size of the grid.
If I enter a grid size of 0.5 m the simulation works perfectly but if I enter a grid size of 0.05m I have the RecurionError.

I have 5 grids with the following areas :

  • 2190 m2
  • 1039 m2
  • 355 m2
  • 151 m2
  • 129 m2

Is it because I reached a grid points limit ?

I tried the LB versioner but I still have the problem.

Have a nice day !

Hi @GeoLaFrite, This post is 3 years old! You should create a new post and share more information about your model and run. See here: Ladybug Tools Forum Guidelines - faq - Ladybug Tools | Forum