Rhino 6 - SplitFloor2ThermalZones


#1

@chris, could you check Honeybee_SplitFloor2ThermalZones component in RH 6 before your Rhino is valid?
SplitFloor2ThermalZones.gh (497.0 KB)

Thanks.


SplitFloor2ThermalZones fails sometimes
Rhino 6 and Honeybee Intersect masses issue
#2

@hdimor.mr ,

I moved this question to its own topic as this is separate from the splitBuildingMass issue. @SaeranVasanthakumar is the author of the current SplitFloor2ThermalZones component and he may have a better idea of how to add Rhino 6 support than I do. Still, I’ll look into it and see if I can find the cause of the issue.


#3

@chris, I can take a look at this problem. It might take a while because I haven’t downloaded Rhino 6 yet, and haven’t worked with any of its libraries… but I guess I can’t avoid the inevitable switch towards it anymore :slight_smile:

@hdimor.mr can you clarify what bug is occuring in the component?

-S


#4

Hi @SaeranVasanthakumar ,

Honeybee_SplitFloor2ThermalZones error report:

Runtime error (MissingMemberException): 'NoneType' object has no attribute 'ToBrep'

Traceback:
  line 2112, in straight_skeleton, "<string>"
  line 2172, in main, "<string>"
  line 2246, in script

Rhino 6:

Rhino 5:


#5

@SaeranVasanthakumar ,
I can confirm that the part of the code that’s failing is the extrusion of the curve, which seems particularly odd. If I get time to look deeper into it, I’ll report back here.


#6

@hdimor.mr, @chris

Well guys, this might be a little anti-climatic but after downloading Rhino 6, with Grasshopper 1.0.0005 (March 31st, 2018 release), it looks like everything works fine.

I wonder if this latest version of GH fixed our problem for us? I tried a couple of different geometries to make sure and I can’t get it to fail. @hdimor.mr can you try your file again with the latest GH release?

S


#7

Oh, and one more point: I’m using IronPython 2.7.7 as per these instructions: http://developer.rhino3d.com/guides/rhinopython/python-troubleshooting-install/.


#8

Thank you @SaeranVasanthakumar for your response,
I did your suggestions but did not happen any change.


#9

@hdimor.mr

Just to be sure, can you check which version of ironpython you’re using, like so:


#10

Yes @SaeranVasanthakumar , I installed the same version and did that http://developer.rhino3d.com/guides/rhinopython/python-troubleshooting-install/


#11

@hdimor.mr

Okay upon further inspection, my Rhino is actually referencing an IronPython.dll from the Rhino folder which is version 2.7.5.0

Can you type, run and report back on the following in a ghpython component?

If you have two different IronPython.dll’s on your computer (like I do), yours may be referencing the wrong one, which we might be able to fix by resetting your system path.


#12

@SaeranVasanthakumar, Here is the report:


#13

Thanks @hdimor.mr, looks like we’re referencing the same .dll.

I just checked, and I also am using a Rhino that was released a couple of days ago. Are you using this update?

If that is the same, then what I’ll do is download Rhino 6 on my home computer and see if I can reproduce the error from your file there.

@chris is this problem still occurring with the latest Rhino 6 and Grasshopper release on your computer?


#14

@SaeranVasanthakumar, Great!, After I update Rhino to most recent version (6.3.18090.471, 03/31/2018) split Floor 2 Thermal zone works fine.

In release recently version.


'NoneType' object has no attribute 'ToBrep'
#15

Awesome, glad you got it to work!

S


#16

Ah gosh. This whole conversation was going just as I found the solution by editing the code. Well for those who don’t go the update route here, I just fixed the one Rhinocommon function that was failing and I pushed it to the github:


#17

@chris that’s helpful, and I’m glad you had a chance to refactor too!

S