Run Energy Simulation 'Zone has no surfaces' error

Hi!

I am trying to run a energy simulation of a simple test room and I have this error:

** Severe ** GetSurfaceData: Zone has no surfaces

The message that I get out of the runEnergySimulation component says that a few of the surfaces are removed because they have less than 3 identical coordinates.

Does anyone know why I get this and how to fix it?

Thanks!

thermal simulation Energy plus.gh (566.6 KB)

1 Like

Without checking your file i would suggest to check the units (must be meters).
Also start checking backwards from te sumulation component. See if the created thermal zone is closed, if the surfaces defining it are correct, etc.
-A.

It was the units. Thanks!

Hello @M.Gkaintatzi and @AbrahamYezioro,
I also can’t run a HB simulation due to the same error. I’m trying to change the units so my HB model can run. But what exact tool should i use to change the units? I’m using LB_Legacy.
I’ve tried the helpful replies from @AbrahamYezioro and @chris here How to change units still same error.
But I can’t figure out exactly which tool/s to use and how to use them.
Thx so much!

to change units so my HB simulation can work right, which tool/s should use and how?
thx.

To change the units to mts (or whatever units you want) you should use the rhino command “units”. A window will pop-up. Theree you set the desired units. It will ask you to rescale the model or not. You probably should say yes.
-A.

Thanks so much for your prompt response @AbrahamYezioro. The simulation seems to run fine now (my first one!).
Just for other novices: seeing the comments on @chris youtube, other pple face same issue. so, as you start, ensure your rhino model units are meters (and that you’ve verified measurements after rescaling in rhino). then import breps into HB and it simulation should work fine.
Thanks Abraham!