runRadiance component for daylight simulation

Hello, I am trying to run a daylight simulation but apparently, tu even run it, it says that _write has to be set to true. what components are needed for it to work? the error says "use radlib_path method, but I cant seem to find that component.

Please extract and place this (337.7 KB) folder at “C:\Users\YOURUSERNAME\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\honeybee_plus”

1 Like

@chris @mostapha @devang thank you so much I was finally able to install LAdybug tools, by dowloading the file and then rerunning the install gh file. But now when using it, I am getting messages like this in multiple scripts that require _write. This is one example, during installation did I do something wrong with radiance? It seemed to be installed correctly but it gives me this message.

@devang I did but it still gives me the same message. Could it be something else? Is it the right folder you provided? That folder is almost 1.5 MB which does not match the size you mentioned.

I have also attached the file for reference.

Thank you so much!
annual_daylight_gridbased.gh (64.6 KB)

I tried you file and it runs fine without any errors. I recommend you delete honeybee_plus folder, restart rhino gh. do a fresh install of honeybee plus, restart rhino gh and then try your file.

@devang I deleted and re installed and the same message appears, could it be something else blocking that path?

@devang @chris @mostapha I was able to run it in a coworkers computer but for some reason it isn’t running like he is supposed to, I am attaching pictures, just to be sure, it seems to be something to do with the windows components, is there a way to fix this?

@devang @chris @mostapha I redid some components of the definition. But I still have the same results. It seems that is reading the surfaces fine, then why could it be giving an sDA of 100 and a ASE of 0?

Here is the updated script: annual_daylight_gridbased.gh (225.6 KB)

flip the floor surface.can you try this file?annual_daylight_gridbased.gh (221.5 KB)

This worked!! thank you so much!!! @Teja5zz