SDK Documentation Search is Broken

Hi @chris, I absolutely love the SDK sites but the search functionality isn’t working for me. I’ve tried allowing Javascript (which I believe my browser does by default), I’ve tried both Chrome and Edge, and I’ve also tried the search functionality on Sphinx’s own website which works fine for me (I assume they use their own search functionality on their website).

Do you know if this is an issue with my PC/browser, or something on the LBT end?
Thanks in advance

Thanks for letting me know @charlie.brooker . This has happened in the past because of incompatibility between several different Sphinx dependencies. So it’s not on your end and I’m fairly confident that I can fix it by changing the CI that generated the docs. Is honeybee-energy the only package that you know of with the issue right now or are there others?

Actually, I realized that this is broken in most of the SDK doc pages. I just made an attempt at updating the honeybee-core docs and the Search functionality seems to work (among a few other improvements that they seem to have made in the updated version of Sphinx):

Can you confirm that the docs for honeybee-core look good to you? If so, I’ll start rolling out this change across the other packages when I get the chance (honeybee-energy will be next).

Thanks @chris, can confirm it’s working on my end.

Thanks, @charlie.brooker ,

I just updated the honeybee-energy docs and you should now have the search functionality here. It will take me a while to update the dependencies for all of the other packages but I’ll get to it gradually over time.

If you or anyone else needs the docs updated for a particular package sooner than later, just post here and I’ll make sure to prioritize it.