SelectSkyMTX runtime error

Hi all,

First of all, thank you for an amazing software.

I am running into some problems with the SelectSkyMTX component. See attached figure.

I tried manually doawnloading the gendaymtx.exe and putting it in the c:/ladybug as you suggested here:…

but that didn’t make any difference for me. Any ideas of what might be causing this problem for me?

Try to put it ALSO in C:\Users\YOUR_USER_NAME\AppData\Roaming\Ladybug

It may be somehow related to writing permissions in your directories.

Maybe this will help.


Hi Abraham, thank you for your reply.

Unfortunately this did not work for me. In fact, there was already a gendaymtx.exe there. I tried deleting it and placing another gendaymtx component there, but that didn’t work either.

Have you tried to update all components to the last version in Github?

Thanks, I was just doing that when I came back to the discussion and saw your reply. This worked for me, i.e. I manually updated all the HB and LB UserObjects from Github. Thanks Abraham for taking the time to look into my problem!

Glad that this fixed it. I am not sure what the original issue was. How old were your Ladybug components before you updated Orn?

Hi Chris. I downloaded the components from food4Rhino around mid September. I thought it was maybe a firewall issue at the office, but I checked that and the firewall wasn’t blocking anything related to Rhino/Python/Grasshopper/LB/HB.

“How old were your Ladybug components before you updated Orn?”

I know what you meant but I just read it differently and made me laugh loud! Very nice question.