Self-shaded meshes in freeform facade surface

I am trying to model a self-shaded freeform facade using Ladybug. The resulted mesh that I obtain from the ‘shade’ output from ‘shadowRange’ component looks incorrect or opposite. The meshes which should be sun-exposed are ‘sun-shaded’ in my model. Attached is the file. Need help to fix it. I would appreciate if somewone explain me the logic/algorithm to locate the ‘self-shaded’ meshes. Thanks. (403 KB)

Flip the test geometry!

thanks Mostapha !..gr8 help :slight_smile:

When I am calculating radition, it takes less time, and therefore, galapagos works smoothly. But, when I am calculating the shades (number shaded meshes) using ‘shadowRange’ component with the changing of parameter, it takes long time, and that is why, galapagos does not rum smoothly; in fact, it hangs. Any solution? My main aim is to do optimization of a free-from facade to get maximum number of self-shaded meshes. Thanks !


Try to use sunlight hours component for a single hour. That is basically the same as what you’re trying to do and it is much faster.


In fact, I started my optimization with a single hour by fixing it 12:00 noon. Do I need any special command to make it ‘singe hour’?

Thanks !

Attached is the ghfile. I feel difficulty to use sunlighthours component; there is no sunvectors, so I am not able to use it for shadowRange for finding self-shading meshes. Could you please check the attached file.

Thank you so much ! (406 KB)

There is a sunvectors input! Check the attached file. If your case doesn’t have direction and sunlight on both directions of the surface is acceptable then you need to test to surfaces with flipped normal and check if any of them receives sunlight for each cell. (406 KB)

Dear Mostapha,

A great help ! Thanks a lot !