Sensible and Latent Heat Recovery error: unsupported operand type(s) for +: 'str' and 'float'


I’m new to Ladybug and Energy plus and I’m trying to specify sensible and latent heat recovery in my HVAC Air details but the Energy plus simulation won’t run and throws me a:

  1. Solution exception:unsupported operand type(s) for +: ‘str’ and ‘float’

I’ve tried entering the data in a panel as a string with quotations:
“0.71” and as a slider but it keeps giving me the same error and won’t run the simulation.

The only way I’ve been able to run the simulation is by letting these values go to Default.

Is anyone else having this problem? Am I just not entering the right type of data?

  1. For questions like this you should copy the full error message from readMe here. We can’t see all your inputs so it is hard to say. The number of line for the error should most likely give a clue on which import is wrong.

  2. To add systems to your simulation you must use the OpenStudio component not the EnergyPlus one.

Thanks for the reply @mostapha !

Here is the full readme output:

  1. Current document units is in Meters
  2. Conversion to Meters will be applied = 1.000
  3. Current document units is in Meters
  4. Conversion to Meters will be applied = 1.000
  5. [1 of 8] Writing simulation parameters…
  6. Can’t find ddy file next to the EPW.
  7. Extreme values from the weather file design will be used instead.
  8. [2 of 8] No context surfaces…
  9. [3 of 8] Writing geometry…
  10. [4 of 8] Writing Electric Load Center - Generator specifications …
  11. [5 of 8] Writing materials and constructions…
  12. [6 of 8] Writing schedules…
  13. [7 of 8] Writing loads and ideal air system…
  14. Runtime error (TypeErrorException): unsupported operand type(s) for +: ‘str’ and ‘float’

line 599, in EPIdealAirSystem, “”
line 2320, in main, “”
line 2445, in script

So for adding systems with OpenStudio, will I still be able to run the full simulation in EnergyPlus? Or will it only be recorded as a system in OpenStudio to be simulated in OpenStudio?

I have the same issue and I’m alright using the default recoveries but… what are they? I can’t seem to find any information about what they are :confused: