Set zone as unconditioned?

Is there a way in the ‘Honeybee_Assign HVAC System’ component to set a zone as unconditioned or is the only place to do that within the ‘Honeybee_Masses2Zones’ component which is typically found much earlier upstream in the script path? If no other way, is it a workaround to include ANOTHER Masses2Zones component later in the script to identify unconditioned zones or does that cause issues and remove any parameters previously identified for those zones upstream?

What if you don’t pass the zone through the HVAC components? In that case it will stay unconditioned assuming you have set it up like that upstream. I don’t think you need a second component for that.

i’ll look into that mostapha! so is a “-1” (Thermostat only) in the HVAC System Assign NOT mean unconditioned?

I don’t remember. @chris or @MingboPeng can probably help.

This is admittedly a workaround but the “-1” option will ensure that no HVAC system is written for the zones that have it. It will still write a Thermostat object for each Zone but this Thermostat basically has no meaning since it’s not attached to an HVAC system. EnergyPlus will still run fine with just the Thermostat but no HVAC for the zone and will result in an effectively unconditioned zone.

BTW @mostapha , having a conditioned Zone that is not passed through the HVAC component means that it will write an ideal air system for the Zone (the “-1” avoids the writing of this ideal air system).

I just did a test and confirmed that a 2nd Mass2Zone DOES in fact erase all parameters identified upstream, so definitely don’t want to go that route!

thanks for the additional info @chris…one thing I did notice when testing the “-1” option is if you run an HBzone that is associated with a “thermostat only” HVAC system, the “Honeybee_separateConditionedUnconditioned” component does not recognize the zone as Unconditioned…i’m sure this component is more reading the output of Mass2Zone _isConditioned, but just thought I would mention.

As I said, the -1 option is a workaround. It gets the simulation to act like it’s an unconditioned zone but it doesn’t change the actual property on the object.

Yet another option is to pass the zones you want to be unconditiond through the Create EP Plenum component like so:

Of, if you still want to keep all of the other schedules and loads, just make your own component with a few of lines of Python: (459.6 KB)

1 Like

thanks @chris…amazing!