Setting an ACH infiltration rate instead of M3/facade area in new HB

Hi Team,

I’m delving into the latest release of ladybug tools version 1.0 and noticed that there doesn’t seem to be an obvious way to input ACH as a parameter for infiltration rates. Commonly, our standards and modelling methods in New Zealand/Australia call for the use of 0.25 or 1 ACH at various points of the day, but I am unsure how this can be translated to flow per external area.

The legacy Honeybee had this set up which required the input of the HB zones first, and had a handy converter for assigning ACH, so I understand how the methods could be different here.

Is there perhaps a component which I am overlooking that could help me here?

Thanks in advance,

Hi @ElzineBraasch ,

You are right that there’s no component like this right now but it is easy to add. I think I will integrate this functionality into a component that also addresses this issue where people want to assign internal gains as fixed values (aka. not normalized per area):

I’ll put methods in the core SDK for assigning infiltration both as a fixed m3/s and as an ACH so it will be easy to set a fixed infiltration value with one line of Python. But I think I’ll only expose one on these two options on the component. Am I right that you would rather specify infiltration as an ACH value instead of a m3/s value?

I also support this @chris.

Yes please. Almost all of our criteria are expressed in ACH rather than m3/s/external area as is currently the only input.

@ElzineBraasch and @AbrahamYezioro ,

I just added a new component to the code base that does that auto-calculation and assignment of loads based on an absolute number. You can get it by running the Versioner component and you can see how it works in the attached file:
image (120.0 KB)

FYI, as I was putting the sample file together, I uncovered a fairly critical bug that I fixed before adding the new component. Thankfully, the bug only affected 2 components from the last release (“HB Apply Load Values” and “HB Apply Room Schedules”) and, the bug only happens for the case that those components are used to edit rooms directly (everything is fine when they are used to edit programs). However, I labeled the bug as critical because it caused a mis-match between the loads displayed in Rhino and the loads that actually ended up in the energy simulation, which is understandably a big issue. This bug fix might be big enough that I update the link on Food4Rhino over the next few days but I’ll have to see. In the meantime, make sure that you either have the latest development version with the bug fix or, if you are using the previous release, you should do your load/schedule assignment through programs instead of applying load values and schedules directly to rooms.


Thanks @chris,
Appreciate, again and again, your efforts.

Thanks for the fix @Chris. Even i came across this issue but i thought something i was not doing right in my script. Anyways this confirmed it was abug and now fixed. Thanks a ton.

Hi Chris,

I’ve sync my file and updated my ladybug tools, however the file won’t simulate with these new components. My file only needed the new solv adj components in the workflow. I had thought perhaps the reason the absolute component was throwing up errors was because the components aren’t up to date in the actual file - but in now updating the file itself and replacing those components that are out of date manually, the same error is coming up that the absolute component was giving.

I may be doing something wrong in updating the file but I’ve replaced everything highlighted in red that needed replacing…

I’m not going to be able to share my gh file for this as its a confidential project

Actually, now since updating ladybug tools none of my old files will run :frowning: Get the errors
run.log (6.3 KB)


Hi @ElzineBraasch ,
It looks like your components are the most recent development version but your core libraries are not updated. Re-run the “LB Versioner” component to make sure that your installation is all in sync.

Hi Chris,

I’ve done this a number of times with restarts now. Wondering if this here is what is blocking me?

If I’m not using the new features, is this step still needed?

No, that one is not the issue. What does the “HB Check Versions” component show you for the versions of your engines?

Is it just like this?

No I have the 3.0.1 for openstudio

Unsure if the versions will be the issue unless the version required has been changed from the new updates. I had been running the same files just this morning before I updated the tools…


I am currently doing things on two computers to save time, and only one was updated so the other computer is able to plot on so no immediate stress in solving this

Using OpenStudio 3.0.1 is definitely good (sorry I forgot that I had 3.0.0 on my machine).

And, ah, that is probably the issue, then. You have two different versions on each of your two machines. Are you sure that you have run the Versioner recently on both machines?

I’ve set up the new honeybee 1.0 version on both computers roughly the same time. There should be the same versions on both to begin with, but I had tested the new absolute component on the remote computer (which involved all the above, updating ladybug tools, etc) but thats resulted in the files created a few days ago to no longer be able to simulate (getting the above run.log errors).

Its a head scratcher for sure. Theres no real reason from what I can tell for it not to work…

Hi @chris,

The remote computer is sadly still not running the file which works fine on the other, not-updated computer. I’m thinking I need to copy the ladybug tool folders from the working computer to the other computer to have that side working again (as it was working fine before the update). I’ve tried to update the remote computer again as I see there was an update 4 hours ago, but still has issues.

Which folders need to be copied over to replicate the same on the remote computer?

@ElzineBraasch ,

Other than the simulation engines, all of the code for the Grasshopper plugin lives in the following locations:




So deleting and copying over those two folders effectively transplants your installation from one computer to another.

Hi Chris,

Thanks :slight_smile: I ended up deleting ladybug tools entirely from the remote computer and re-installing it. It works for the file now like before.

Something must have gone wrong with the updating.

Thanks again for your help!

1 Like

Hi @chris,
Oz and NZ standards call for ACH to be inputted as a schedule. Similarly to ElzineBraasch’s request, can you please add a ACH input to the HB Infiltration component?

It would look the same as the HB Ventilation ACH input.