Shading mask II ends with an Solution exception

Hi everyone,

I wanted to try and test the shading mask components for some further analysis. Problem is, that when trying to drag the Shading Mask component, on an empty canvas, the whole Rhino crashes (even without any geometry in the model yet).

When using the Shading Mask II component, I get no results and I am left with this warning:

  1. Solution exception:‘NoneType’ object has no attribute ‘PointAtNormalizedLength’.

I tried connecting the context as a whole as well as individual faces with the same result. Tomorrow I will also try this on a desktop PC. I am running it on Rhino 7 together with the Ladybug Legacy 0.69.

Is there something I am doing wrong, or may the problem be somewhere in my installation?

Simple file is here: (383.5 KB)

Hi @zdenom. You can refer to this post.

Hi all,

I am trying to use the shading mask II component but getting a different error -

  1. Solution exception:need more than 1 values to unpack

If I assign a brep there is a different error -

  1. Solution exception:‘NoneType’ object has no attribute ‘PointAtNormalizedLength’

I referred to the bug fix post linked up also, but the code for shading mask and shading mask II component are different.

On a side note I have accelerad integrated with my radiance. Not sure if that’s causing any issues.

or anything basic I am missing. i remember successfully using this component in the past. Now I have a new laptop and
its not working on this machine.
cc @zdenom @Asisnath (375.4 KB)