Snappyhexmesh does not read features

I changed that before continuing with ‘blockmesh’, but however, it is still the same

I wonder does the terminal show you an error? I would definitely look there instead of the GH component output. I am just curious if it is finishing on the terminal. In any case, OF will give us a much more detailed error message there.

the error shows at ‘loadprobevalue’ component since the solution component does not iterate at all, then I found the snappyhexmesh didn’t run correctly.

Aha ok. Have you perhaps updated the BF components? The original GH file should be outdated.

no I haven’t update the BF package but this situation first appeared when I tried with a simple box which is very similar to one in the deafult indoor cfd gh file. But it didn’t work, so I move back to the defualt one and notice that the same errors shows again. Do i need to reintall my BF and Openform?

You should definitely update BF to the last version (there is a component in the 00 tab or you can download from food4rhino). And if you don’t have it, you’ll need to download BlueCFD ( to be able to run that version of BF out of the box. There’s installation instructions on github.

I download the BF in the early of this month, as well as BlueCFD.
At the begining, the BF is working, but somehow the solution component couldn’t iterate anymore then I test it with the most simple defualt gh file.