Snappyhexmesh does not read features

hey, I am recently using butterfly for indoor testing. I create a single box with two voids represent inlet and outlet, however, I have some problems with the snappyhexmesh component.
There is no error with it, but it just can’t read the features. I have searched on the internet and couldn’t find the similar issues with mine.

I upload the image here, any help or advice is appreciated.
by the way, the unit is meter.

Hi @Monica You should upload some screenshot of your model and the meshing.

I would definitely try and set my model units to meters. It seems you’re working with mm at the moment, that might cause some issues.


thank you for replying, but i have mentioned that in the original message that the unit i set is meter

hey, mingganyin:
thank you for replying me. I attach the GH file here.
Acutally the script i used is the defualt indoor butterfly simulation from its (433.8 KB)

Hi Monica,

Your bounding box coordinates indicates that this is an extremely small space. Perhaps you need to adjust the size of your geometry to meter scale?

hi TheodororsGalanos

I used the defualt indoor cfd gh file that i download from its webside which does not have objects in rhino, and i have checked that the unit setting in Rhino is meter.
do you have other advices?


i upload the screen shut image here

Hi Monica,

In the picture you have shared I can see the bounding box have the following coordinates:

(-0.0006 -0.0006 -0.0012) (0.106 0.106 0.0072)

That is a very small region to mesh and it might be why it is failing.

Could you maybe open your blockMeshDict file (it’s in your C:/Users/your_user_name/butterfly/your_case_name/system folder. In the top there should be a line starting with “convertToMeters”. Can you let me know what the multiplier is after that?

sorry i couldn’t find that line so i upload the log file heresnappyHexMeshDict (3.1 KB) surfaceFeatureExtractDict (1023 Bytes)

Could you maybe upload the file called blockMeshDict. Should be the one we need.

sorry i just found that and here is the lines:

here is the fileblockMeshDict (1.5 KB)

thanks. I wonder if the case was generated when rhino was set to mms.

Could you try deleting the case and just remaking it from your definition? Then please post the same file again. If BF is doing what is supposed to do that should work.


i am sorry i may not understand you well. Do you mean delete the ‘blockmesh’ log from the local file and run the snappyhexmesh again? i have tried this which does not work

also i rerun the script from ‘create openfoam case’ by making a new case which shows the same problem

I mean delete the whole case folder if you can. Then rerun the script if possible. And share the blockMeshDict file again.


do you mean to delete this case?
actually i have tried several times and haven’t got a right one yet

Yes, delete it. Make sure rhino is in meters (if necessary restart it and GH). Then rerun the GH script.

i rerun the rhi and gh again, here is the ‘blockmesh’ fileblockMeshDict (1) (1.5 KB)

Again so weird. The bounding box coordinates are now in meters which is correct, but the ConvertToMeters factors is at 0.01. Are you sure you are setting everything in mms? It’s weird.

In any case, if you change that line in blockMeshDict to 1 it should work.