snappyHexMesh - Non-orthogonality

Hi!

I am running a natural ventilation study of a house (9x9x3m), which was modeled as an Outdoor case. BF geometry has 4,4 values for the refinement levels.

The wind tunnel data comprises 44.97 * 82.21 * 18.20::dir (0.0 1.0 0.0)::1.100 m/s
I used tunnel grading, the blockage ratio is below 3% and snappyHexMesh settings follow the example file of the Natural Ventilation study from the Webnar: OpenStudio CFD training using butterfly.

However, when checking the mesh in Paraview, the edges are not orthogonal and the max value when checking for non-orthogonality is 60,32 with an average of 11,24.
(It seems a good value would be around 50, although the default max value from BF is 60 and I can`t find a way to change it)

I’ve tried different settings, but I don’t seem to be on the right track.
Could someone help me to get a good mesh, please?

Thanks! =)

Hi,@Nayara Butterfly used snappyHexMesh for meshing. It is hard to control the quality of meshing. Could you upload the grasshooper file for further discussion?

Hi @minggangyin,

please find the files attached.
The study encompasses a 3-story house, but at the moment, only the ground floor was incorporated into the Grasshopper model. I am taking baby steps here, trying to make one thing work at a time. Thanks for helping!

BFGeometry.zip (241.2 KB) Nayara_CFDStudy.gh (578.5 KB)

Hi,@Nayara
Here is the way to change the max value of non-orthogonality.


According to my experience, you shoud set min and max value of building using different number.And set the resolveFeatureAngle to 90 or smaller.

Hi, @minggangyin
Thanks a lot for your contributions. It has already cleared many of my doubts.
However, when I run the model with the same configurations from the image you sent I don’t get an image like yours. Could you please send me the file you run?


Besides, the non-orthogonality check remains above 60, although the limits are set to 50.

image
Should I try different option until I reach a value below 60, or may I move forward, even with such value? I am afraid that I will generate unreliable results if the mesh does not have fulfilled the quality control.

@Nayara Current mesh is enough good for solver.You should move forward.
Here is the grasshooper file.
Nayara_CFDStudy-fix.gh (580.2 KB)