Solution exception:'ShadowCalculation' object has no attribute 'setCalculationFrequency'

I have met a problem running the honeybug…
can someone tell me how to solve it?

Same error any update on this. Anyone?

Someone please help me on this how to overcome this. This stopping me from working hope any help please. Dear admins @mostapha @chris @devang @AbrahamYezioro

You should help yourself first. Read the guidelines for posting here.
Please upload a simplified version of your file with the geometry internalized. Just asking a question without providing further information is not helping you.

1 Like

Being new doesn’t mean you can’t try first to understand and solve by yourself. our file doesn’t have any algorithm using any LB_HB components.
I suggest you look at the hydra website for examples.
Sorry but this is beyond helping what you are asking.


Do you think without trying myself i directly step down into forum? If your answer is yes, sorry i tried my maximum with hydra already and even completely watched Chris’s playlists for LB_HB somehow i missed what I’m trying to achieve so i redirected myself here. Secondly many links to examples files also broken there in your Gitbook Honeybee Primer and in your official website check examples link too. Finally i myself just seeking for an advice for how to apply this to my type of model which i posted above the complete test gh file or case study. Chris YouTube video case study have only box model including his parents house model but that’s not my case so i find little difficulty to incorporate that to mine. Sadly i couldn’t get anything. Thanks all @AbrahamYezioro @chris

Hey Missi, did you ever figure this out? I’m having the same error pop up and can’t figure it out. I’ve tried adding energy simulation parameters because I saw this in another thread, but I then also get the error “1. Solution exception: Failed to import ladybug: No module named ladybug.dt” @AbrahamYezioro @chris

I guess it may be the Openstudio version. I had the same problem with Openstudio version 3.0.1, but when I uninstalled Version 3.0.1 and still used the old version 2.9.1, there was no problem – Solution Exception: ‘ShadowcalculationFrequency’ Object has no attribute ‘setCalculationFrequency’

same here. Had the same error using OS 3.1, rolled back to 3.0.1, the same. Could only fix it by reinstalling OpenSTudio 2.9.1…


I have had the same problem.
Should I uninstall OpenStudio 3.0.0, 3.0.1 and 3.1.0, and then should I reinstall OpenStudio 2.9.1?

To be honest, I am a bit afraid of uninstalling the versions, because if I do it, it could cause another problem with other scripts.

Thank you

Hi Syo,

It turned out that even when I fixed the openstudio error by reinstalling it, I still was unable to run the sample files, more errors kept popping up. I just stopped playing with the Legacy files and started anew with the LBT1.2. I recommend you doing the same as the latest version seems more stable, and it’s easier to install and maintain.

I had the exact same error, Chris guided me through. So basically check the Ladybug_Ladybug component version, and the exporttoOpenStudio component’s version, if they don’t match, try updating the components. Make sure you have the Openstudio, radiance etc exact version that the software requests installed in your PC, if that doesn’t work, maybe its due to faulty geometry

1 Like

Check this discussion here

This one is also useful

Hi I’m having the same issue
This is my current setup:
Energyplus 9.5.0, openstudio 3.2.1, Rhino 7, new pollination plugin.
I’m trying to follow the academy video “Energy and Comfort Modeling for Passive Design” part 2.
In the part 1 video Id had to fix the .DLL problem to run Openstudo grasshopper component.
I was able to fix it by replacing theDll flies from this address:
Now the part 2 video sample file is giving me the" 1. Solution exception:‘ShadowCalculation’ object has no attribute ‘setCalculationFrequency’" red warning error.
The honeybee and ladybug components are all updated. That solution did not solve the issue.
I’m sure the file will run in older openstudio and grasshopper versions, but 3.2.1 is the one I need to use since is the first one with ASTM C1340 EMC built-in.
Does anyone know if this “ShadowCalculation’ object” has a fix?

HouseEnergyModel.3dm (602.1 KB) (662.0 KB)

Use OpenStudio 2.9.1. See here:


I had the same error mentioned in the title post but was using the hydra file. As per your suggestion, once I replaced the LB_LB, HB_HB and exportToOpenStudio component to the latest ones everything worked fine.
using OS 3.2.0, LB_HB legacy v1.3, R7

1 Like