Solution exeption:'NoneType' object has no attribute 'name'


After the LB HB new version update I am getting this error after the annual simulation.

I have been working on the file with the locked solver after the update, but I did not modify much the parameters for the analysis. I have tried several modification to see where the error could be, but without any result.
Since the file is rather complex, do you know what this error refers to?

Best regards,


It helps if you post the whole error report from out output. The number of line can help to understand what is the source of the error.

If I have to guess probably one of the surfaces that are connected to HBObjects in None.

Hi @mostapha,

thanks for your reply.
This is the error I got from the component

I checked the surfaced as you suggested but everything seemed normal. I made some variations and tests, but always the same issue.

The only odd thing I saw, while I was checking is showed in this picture

A you can see there is no error on the component, and a hbzone is outputted. Nonetheless some warning, that I could not see completely, is showed.

I uploaded also the file, a simplified version of it, if you have any insight.
Always appreciate your help.

Best regards,

Federico (651.3 KB)

I can’t regenerate the error with the new version. Can you try this file and let me know what happens. (659.0 KB)

Hi @mostapha,

thanks very much for having a look at it.

First of all this message appears when I open the file

This same issue happened me opening GH after installing the new version of HB [+]. I did think of mention it before, but now I think it may be important. It happened in the 3 computers I have installed the new version in.

Once I opened the file this message ballon appeared but I did not change the component, as I think that it is because the 2 and 3 layers has been removed.

I set boolean to true to run the simulation, but no system window appeared. Nonetheless this is what it showed

It seems that no ill files have been generated

Please let me know how to proceed.
Best regards,


This is because I’m using Grasshopper 1.0.0004 which is a newer version of Grasshopper. You can just ignore this warning.

Your assumption is right. The component is sensitive to changes in number of inputs and outputs. In case of components with dynamic number of inputs you can just ignore this message.

By looking at the screenshots run should be set to False. Double check the inputs.

You were right! I did not see it!

I run the simulation and this is what appeared on the canvas

Just by looking at the file what I saw is this:

And this is the output from the annual analysis component

Thanks for the help,


You have pressed Escape which has cancelled the solution. Try to run it again and it should run fine.

Hi @mostapha,

this is what happened next

I run first a simulation and it seemed that it worked. I run again another one, in another folder, and this is what happened.

Thanks for the help.
Best regards,


@Federico587, Does the error go away if you right click and Recompute the solution?

Hi All!

I came across the same error.

Grasshopper Error - Solution exception None Type object has no attribute name.pdf (169.5 KB)

I followed up the post, but I could not find what is wrong. Could someone look at my script?

DA (546.0 KB)


HI, i am getting the same error. all im doing is to follow the tutorial on grid based analysis for DF. I created a box with surfaces and set all of them az brep and then connect it to Mass2zone. it gives me the test points but does not go further.

but if I only create a box, it works. but my real project is not a box and I have multiple surfaces.

@JanuaryJune Which version of Radiance are you using? You should use Radiance 5.1 or newer .

yes, its 5.1. I dont think thats related to the version. its something about the geometry. doesnot like the way I choose my walls and floor.

hi all
i have a problem in HoneyBee_masses2zones when i connect it to HoneyBee-intersectmasses.
the error is:1. Solution exception:‘NoneType’ object has no attribute ‘Centroid’ (626.0 KB)
could you please help me