Solve adjacencies component not recognizing all walls. Honeybee energy simulation

Hi all :slight_smile: ,

I am attempting to do a zone sizing and full energy simulation of a building project.

Honeybee however, is causing missing walls after solving adjacencys. (Please refer the images attached)Error1

It is causing energy plus to crash when I attempt to simulate through honeybee directly.

Is there a way to manually correct missing walls like you usually can in openstudio? or do we need to rely completely on the solve adjacencies component to do things correctly.

I considered using the intersect masses tool, but this would then make it impossible to differentiate between various spaces.

Could you please tell me how I can correct this issue? And if there is something wrong with my script.

Also note, the add glazing and context shading values are all fillers at the moment.
Have attached my ladybug and grasshopper files here (953.6 KB)
3Dmodel.3dm (2.0 MB)

Can you share the file?

Kindly setup a profile picture.

@devang I have been trying too, but it isnt allowing me to upload attachments as a new user.
Profile picture has also been setup

Can finally upload, there you go :slight_smile:

I see your the problem. @biridin, You’ll need to split the surface manually. Since a part of wall is indoors and the rest is outdoor, this error is happening. Please split the surface at such locations to avoid this.

that worked. thank you so much! :slight_smile:
It solved the adjacency issue,
But now my export to open studio file is giving me this error:

  1. Solution exception:openstudio::model::Surface const & type is null

I feel like there might be errors in how I built my model maybe?
Is there some place where I could read certain unsaid rules about how a model should be built?

Have re uploaded an updated file (953.8 KB)

Glad it worked Biren!

Zoning for energy modelling is almost an art. You tend to get better with experience. As a starting point, I would recommend looking at this series from @chris.

Have watched that entire series twice! Only reason I have managed to get this far haha.
Could you please help me with the error ive just gotten again with the export to open studio component? I have edited the comment above :slight_smile:

I believe your geometry needs scaling. Can you please check, scale the geometry, internalise the geometry again and share the file?

The model is built to scale though. It is built in millimeters as a unit. Is that wrong?
is grasshopper unable to recognize 10000mm as 10m?3Dmodel.3dm (2.2 MB)

It is always a good idea to use the unit of Meters while using Honeybee (909.3 KB)

Still getting the same error.
Have scaled it all to meters.

But now also strangely, the top floor open office roof is being recognised as a ceiling. is that an issue?
also, the exposed floors are only being recognised as “floors”. is that an issue?