Solve Adjacencies not working after running the simulation

#1

Hello!

I am facing an issue that I have no idea what it is going on. Follow attatched my script. If anyone could help me, please.

I have solved my adjacencies and also have checked my surfaces using “decompose by type” component to check the adjacencies and “label surfaces” to check boundary condition and also the constructions assigned. When I check it all the surfaces are just as it supposed to be, but when I run the simulation using “export to open studio” I got this issue for ALL my building surfaces:
Example: Adjacent surface Building_2_Srf_27 was not found. Boundary for surface Ap_02_7_Srf_4 will be set to adiabatic.

This is my geometry, with NO adiabatic surfaces before running the simulation.

I dont know where is the mistake, I have tried everything already. If anyone knows what could be happening please help me.

Thank you!

TESTE4_SA_termico.gh (850.2 KB)

0 Likes

#2

Anyone know what might be happening? :wink:

0 Likes

#3

@iris_loche I took a look at your gh file but it looks like you haven’t internalized more then half of the breps needed for your script, which is causing all sorts of unrelated errors downstream.

Can you either add the other missing breps to your script, or simplify the script to work with the breps that are internalized?

S

0 Likes

#4

Thank you, @SaeranVasanthakumar! Follow attatched the script with the breps internalized. If you could take a look, would be of great help. :slight_smile:
TESTE4_SA_termico.gh (890.2 KB)

0 Likes

#5

Does anyone know what might be happening that honeybee can’t find adjacencies after running simulation?

0 Likes

#6

@iris_loche

I haven’t had a chance to test this out, but I suspect the problem is occurring at the IntersectMasses component. Specifically I think the surfaces that are causing warnings in E+ are surfaces that aren’t split correctly (or have adjacent surfaces not split correctly). That’s why for complex conditions it’s a good idea to bake the geometries, and if necessary split surfaces in Rhino, then bring them into Grasshopper.

I would recommend testing this out by isolating two breps that are causing the E+ warnings, baking them, and inspecting their surface intersection. If it’s faulty (i.e surfaces are overlapping) split them in Rhino, and your warnings should disappear.

S

0 Likes

#7

I have made several tests in the geometry and I got the conclusion that this happens in the moment that I insert the windows. The model works just fine without the child surfaces. I have tried to build the surfaces directly in the grasshopper to make sure they are coplanar but I got the very same issue to all my surfaces: Building_2_Srf_27 was not found. Boundary for surface Ap_02_7_Srf_4 will be set to adiabatic

I really dont know what else I should do…

0 Likes

#8

Thank you very much @SaeranVasanthakumar!
Thanks for the help. Everything is much clearer to me now. I will follow your tips and restart de model the way you told me to. Thank you for taking your time to help me. Meant a lot to me!

0 Likes

#9

@iris_loche

Are you sure your building is working without the child surfaces? I have checked and confirmed my suspicion, that the errors are originating from incomplete splitting occurring at the IntersectMasses component, (on my computer using Rhino 6, latest GH, latest HB, OpenStudio 2.5). Furthermore eliminating child surfaces isn’t doing anything on my end.

Here’s an example of an error:

That refers to the surface intersection for these two building elements:

Leaving aside that this isn’t the correct way to model a subset of rooms within a larger building, here’s how the IntersectMasses component splits the surface of the larger volume in your current GH model:

image

As you can see the surface of the larger volume is not split. Thus the interzone surfaces are not the same size and won’t satisfy the conservation of energy during the simulation process. Hence your errors. I’m not surprised you’d have additional errors when adding child surfaces, but you need to address your upstream issues first before tackling them.

That being said, I think the larger problem here is that you have an unnecessarily complex model. I assume you are attempting to assess the natural ventilation of the some apartment units at the top of your building? You shouldn’t be adding these gigantic thermal zones with no windows, to representing large sections of your building. Just represent the apartment units in isolation, and use an adiabatic surface to define the bottom floor. If you need to account for the whole building energy, you can model some more representative zones and use the zone multipliers option in HB to represent a larger mass.

That way, you don’t even need to use the IntersectMasses component to split the bottom of these surfaces, thereby avoiding this problem in the first place. So I would encourage you to first simplify this model, before continuing to debug this model.

S

1 Like

#10

Hello @SaeranVasanthakumar! I did everything you told me to, and also intersected the masses, baked the geometry intersected and created another breps to run the simulation. The geometry is working fine after that, but when I plug the child surfaces it creates an issue. Can you help me again? I am having trouble in creating these surfaces and I dont know I the geometry I create in RHino is not working properly.
TESTE5_SA_termico.gh (804.2 KB)

0 Likes