'solveAdjc' and lost Adiabatic Assignment?

Hi all,

I’m running into a funny problem with the ‘solveAdjc’ Honeybee component and I wonder if anyone has seen the same thing? When I build adjacent zones surface-by-surface and assign adiabatic BC’s to certain surfaces, then I run the ‘solveAdjc’, the adiabatic assignment is getting lost for all my surfaces.

Notice, the adiabatic surfaces are there before running the component, but are missing afterwards:

Of course some of those surfaces are being correctly changed from ‘Adiabatic’ to a ‘Surface’ BC type, but several are party-walls to neighbors in this model and so don’t switch to ‘Surface’ (since they don’t find any adjacent neighbor surface in any other zones) but instead are getting an ‘Outdoor’ BC assignment overwriting their Adiabatic BC?

Is there a workaround that anyone is aware of to preserve my ‘Adiabatic’ assignment on surfaces through the ‘solvAdjc’ component for non-adjacent surfaces (partywalls to neighbors, for instance)?

I’ve attached a super simplified example of the scenario here as well.

thanks so much for any advice.


Lost_Adiabatic_BC_Internalized_Example.gh (490.2 KB)

What happens if you leave remCurrentAdj to False? That should keep the current boundary conditions.

ah! perfect. that worked. I think I misunderstood the note on that input there…


1 Like