[solved] Failed to load EP constructions!

#1

I got the following warning after importing the Honeybee_Honeybee component, although I have copied the files as suggested in the warning…

1. Failed to load EP constructions! You won’t be able to run analysis with Honeybee!
Download the files from address below and copy them to: C:\Users\oat\AppData\Roaming\Ladybug*https://github.com/mostaphaRoudsari/Honeybee/tree/master/resources*

May I ask how to solve this issue? Do I need to install OpenStudio?

Thanks!

1 Like
#2

it seems the Honeybee_masses2Zone component also got the warning about missing the honeybee_OpenStudioStandardsFile (see image 1):

But I do have the two files in the folder (see image 2):

The GH file is attached (LB+HB all updated to the latest version)…

Appreciate your advice!

test_material_construction_v001.gh (624 KB)

#3

… EnergyPlus V8.3 and OpenStudio v1.9.1 are installed, too.

#4

Grasshope,

Your file runs fine for me. Make sure that yoyr OpenStudioMaterTemplate file is unblocked by right-clicking on it, selecting properties, and then unblock.

Also, make sure that the folder you are showing is your default Ladybug folder by looking at the output of Ladybug_Ladybug.

-Chris

#5

Dear Chris, thank you very much for your prompt reply!

However, the problem is not solved after I unblock the two files in the directory C:\Users\oat\AppData\Roaming\Ladybug, and restart the computer.

I also tried the GH unblock file created by Marios Tsiliakos (http://www.grasshopper3d.com/profiles/blogs/unblo… But I assume it only checks the LB&HB user components which don’t include the two files mentioned above.

Plus, I also found that the right-click menu option for unblock is not working using Marios’ file… I didn’t even get the windows to remind me the change of the registration key … Anyway, I shall probably email Marios in this regard.

I also installed multiple version of EnergyPlus in case it is related to a specific version of EP: v8.1.0, v8.2.7, v8.3.0, v8.4.0

So, I’m kind of stuck here… with all the solutions checked so far …

Please kindly advise if I shall check other things that may have caused this issue …

Thank you very much!

#6

the output of Ladybug_Ladybug and Honeybee_Honeybee:

#7

… the following causes another problem while solving one :

  1. out of frustration, I deleted the OpenStudio_Standards.json file from the the default working directory C:\Users\oat\AppData\Roaming\Ladybug

  2. import the Honeybee_Honeybee component onto the GH canvas, and by doing this the OpenStudio_Standards.json file will be downloaded from GitHub and put in the default working directory

  3. now, there’s no warning on the Honeybee_Honeybee component. But I can’t call any construction or material from the Call From EP Construction Library component…

#8

OK, It seems that I need to delete both the OpenStudioMaterTemplate.idf file and the OpenStudio_Standards.json file from the default working directory, and import the Honeybee_Honeybee component so that both files can be downloaded from Github again and put in the default working directory…

Now, the problem is solved.

However, I noticed that both files in the default working directory downloaded by importing the Honeybee_Honeybee component are larger (1.541KB and 1.259KB) than the ones downloaded directly from GitHub (both are 30KB). May I ask why?

#9

It seems that in the code for Honeybee_Honeybee, the github link addresses to download the two files mentioned above are not the same as indicated in the warning message, although they seem to point to the same webpage…

I.e.

https://github.com/mostaphaRoudsari/Honeybee/raw/master/resources

vs

https://github.com/mostaphaRoudsari/Honeybee/tree/master/resources

Is this a bug?

#10

Grasshope,

Your persistence in solving this issue is commendable. After clicking on both links that you posted, I realize that the “raw” link redirects or forwards to the “tree” link so they are virtually the same.

Also, I compared the files downloaded at the links to those that HB automatically downloaded for me and they seem to be the same:

Perhaps this was a case where your internet connection was interrupted while automatically downloading the files in the background?

-Chris

#11

Thanks, Chris!

I agree that it might have to do with my computer system or internet connection. But I’d prefer to maintain the status-qua that is working now than further tempering the software …

#12

Hi Chris and Grasshope,

I am still having the same problem Grasshope described in the first post here but have not been able to resolve it in the way that Grasshope did. I have tried everything from the above but to no avail. The files I get from GitHub are still only 36kB for me (or thereabouts) and they do not increase if I get Honeybee_honeybee to download them itself.

By the way, I have noted that there is no consistency in when Honeybee_honeybee will automatically download the files as it will not do it always if they are not there but so far it only does it for me if I had imported Honeybee_honeybee (not working and no files there) then manually add the files, then delete and re-import Honeybee_honeybee (not working), delete files (after Grasshope’s posts), then delete and re-import Honeybee_honeybee and then it automatically downloads them but it still doesn’t work (gives same message about missing file) and files are still around 36 kB.

The only clue I have to move forward is that my Honeybee version is 0.0.59 and I see from screenshots that Grasshope was using 0.0.57. I also see that Chris has recently changed the EP structures file on GitHub only a month ago.

I will try re-installing an older version of Honeybee but I don’t see version 0.0.57 there, only 0.0.56 and 0.0.58. Which one is best for this purpose and for the new updated Vertical Sky Component to work?

Any help would be greatly appreciated!

Thanks!

Alex

#13

Alexander,

  1. You do not need to have EP constructions to run any of the daylight or Radiance analyses (it is only for EnergyPlus) and so you should not have to change anything to run simulations with the Honeybee_Vertical Sky Component. You are already good to go. Also, as I recall, the VSC component has not changed in over a year - only the Ladybug skyView component changed recently.

  2. You should definitely stick with the most recent release as I can assure you that this issue will not be any different depending on the version.

  3. The not downloading of files if you already have them is intentional since you want to still be able to use Honeybee when you are offline and have installed everything already.

  4. I only added the userCustomEPLibrary.idf as an optional resource recently and this does not have anything to with the OpenStudioMasterTemplate.idf that you need to run EP.

  5. I am getting the correct 1,723 KB file when I go to either of Grasshope’s links (https://github.com/mostaphaRoudsari/Honeybee/raw/master/resources), click on OpenStudioMasterTemplate.idf, then right-click in View Raw and select “Save File As”. Are you saying that you do not get this when you follow the same workflow?

-Chris

#14

Alexander,

To add to Chris’s comments I think you have a firewall that stops the file to be downloaded correctly. Have you tried to open the files on your system by a text editor? Does it look like the one on github?

Mostapha

#15

hi Chris and Mostapha,

many thanks for your reply. I have managed to solve it but not sure how much of it witchcraft and how much I can rationally explain. The long story involves the dowloading and installing of 3 previous versions of Ladybird and Honeybee but nothing different happened. This was all happening on a desktop PC running windows 10 and with a wired connection to the internet router (via a switch). I then tried installing Ladybug and Honeybee on a MacBook Pro running Windows 7 on bootcamp. This computer was wirellesly connected to the same router. The installation of the latest version was very smooth and all the right files of the right sizes appeared without any problem on the first import of Honeybee-Honeybee. I then copied the files over to the other computer. Solved.

  1. good thing I didn’t know that as I wouldn’t have kept on trying to resolve it!

  2. Ok, sticking with it - besides I would hate miss out on such a major release!

  3. Makes sense.

  4. ok, I thought that that was the main file because of the EP in the title - I now have them both anyway.

  5. Now that you say this when I click on the file in github and download it from the view raw link then I do get the right file size. But when I have been trying to download it directly from the root folder (i.e.Honeybee/resources) with “save link as” then I get the 36kB. Could it be that Honeybee_Honeybee was doing something similar?

Many thanks again to both of you - great work out there!

best,

Alex

#16

Alexander,

I think that I figured out why you were getting the 36 KB file. When you right-click on the link under resources and go to “Save link as,” you actually download an github html page for the file instead of the actual file itself. You have to make sure that you right-click on the Raw file to get the real file to download.

-Chris

#17

What if I change the IP address and then try to access? If you don’t know how to do it here is the resource: https://192-168-1-1ip.info/