Speed up the optimization of building form

#1

Hi everyone

I am working on optimizing form for energy consumption. I have more than 14 Breps where each one represents a cubic zone. The file was too slow but it started to speed up when I canceled the “internalize data” from the Breps in addition to minimizing the number of Breps. I want to ask if there is another thing to do to speed up the file without minimizing the number of Breps?

Thanks,

0 Likes

#2

I had a model taking to long because of my units being imperial. I don’t know if that is the issue you are having. Metric runs quicker

1 Like

#3

Hi Fabian
Thank you so much for replying. I do use Metric units.

0 Likes

#4

@Amany.khalil

Not related to the energy simulation specifically, but just working with GH files, enabling autosave will cause internalized breps to be resaved everytime you change anything in the solution, which can slow your GH file to a crawl: https://discourse.mcneel.com/t/internalising-large-amounts-of-data-can-cause-autosave-slow-down/61743

So disable autosave, don’t internalize data, or follow David’s suggestion in the link above for speedier GH work.

S

1 Like

#5

Thank you so much Saeran for the kind help. I don’t have internalized data, but I have disabled autosave hope this will make the optimization go faster. Concerning using data input n output, I am not using Rhino 6 but will try to use it n try this. Thanks again.

0 Likes