Split Building Mass 2 Floors component not working

Split2Floor Problems.gh (459.6 KB)

Hello all!
I am running the same script in 3 computers, daylighting simulation with HB zones. The computer number 1 has HB and LB for a while now so its not the new version, and it runs perfectly. The computer 2 has the latest HB and LB version and runs perfectly. The computer number 3 however, I just installed LB and HB today, does not run in any way, and the problem seems to be the SplitBuildingMass2Floors component.

Firstly I installed the latest version, then I uninstalled everything and installed an older one, and it isnt working.

The error I get can be seen in:

I also tried making a scrip from scratch to see if the component would work and still nothing. This file is attached here if someone wants to take a look.

Some help would be very much appreciated! Thanks!

Try to change Rhino units. For example to meters.

Already did :confused: didnt work. But thanks for the suggestion

Hello there, any solution found yet?

In my case I have the same issue, but only in Rhino 7. When I run my script in my Rhino 6 it works without problems.

It has been an issue with R7. It was solved. You need to update your component to the latest version from github.

1 Like

Right, thanks Abraham, problem solved.

For others, here you can find the updated component:

honeybee-legacy/Honeybee_SplitBuildingMass2Floors.ghuser at 1494fe0f1be514675511b7c19a625264aa31393b · ladybug-tools/honeybee-legacy · GitHub

1 Like