Split2zone problem with square footprints

Dear all,

Maybe you are aware of this, but as far as I can say split2zone behaves strangely when it comes to square footprints. In my definition, when the aspect ratio is larger than 1, it works fine, but when it is 1, the process takes much longer and the resulting surfaces are not exactly the right ones.

OfficeGlazingPar4.gh (526.2 KB)

Hi @farhang.tahmasebi, Thank you for reporting this. I think @SaeranVasanthakumar has already addressed this once before. @SaeranVasanthakumar what is the best approach in this case?

Hi @farhang.tahmasebi, @mostapha

Yes, this was a bug that I solved a while ago. I just tried your .gh script on my computer and the aspect ratio of 1 works fine.

So use the updateHoneybee component to update your script, and it should work.


@SaeranVasanthakumar, I am using Honeybee 0.0.63 and I also ran updateHoneybee in the canvas. But it still does not work for AR of 1.


We’ve also had issues with this component when using an older release of Rhino 6. Which Rhino version are you using? Try using the most recent version: 6.3.18090.471 released on 03/31/2018.

Let me know if that works.

Thanks @SaeranVasanthakumar. I was using Rhino 5.11.50226. I tried it then with Rhino 6 and Split2zone worked fine for all aspect ratios.