Strange results of daylight (point in time) analysis

Hi everyone,

Im running a daylight simulation of a point-in-time and have been getting strange results. Im struggling to understand what is actually wrong in my model.

The enclosed screenshots illustrate the result for March 21st at 12 pm and basically the analyzed grid indicates that it receives neither direct or indirect light which is odd. I have ran the analysis with two different geometrical conditions. To check if the problem is from the geometries I ran both radiation and sunlight hours analysis which were better but still strange. I would greatly appreciate if you have an idea what can be the problem.

Im enclosing the grasshopper definition as well in case its needed.note that the assigned rhino geometry of the groud will be missing in the definition, in which case a simple ground of the target area which is obvious in the screenshots will be easy to make and test i guess. atm I dont have access to gh and cant change the definition.

Thanks a lot for brainstorming with me in advance.


<a class=“attachment”

I took a look at your file. The relevant geometry was not internalised so I could not re-create the error. Please check the surface normal of the analysis surface. It should be pointing upwards.

I know… the way I have built the geometry is not so smart but didnt have time to redo it.

Nevertheless, I have checked the normal of the analyzed surface before and it points upwards. so that shouldnt be the problem.

Any other idea what it might be?

Thanks for checking and the reply.

Please internalise all the relevant geometry and share the file back. So we can take a look.

Thanks for the quick reply. here is the file with internalized geos. Looking forward to hear your thoughts.

S (946.1 KB)

PS. I have also tested the wall surface (labeled as one of the target geometries in the attached gh definition) for Dec.21 at 12.00 with high grid size (3800) and lowered radiance ab value (2) to have a rough test run and as you see attached, the result doesnt make sense. This is while the radiation test of the same surface worked fine (also attached image - for another point of time in the year). I know the solution might be obvious but Im stuck atm.

I took a look at your file. I don’t think there’s any issue. I would recommend using the meters in Rhino and scaling your model to the meter scale.

Hi. hummm… the meter scale is sth that I always forget since I never work in meters. Thanks a lot. I will try and get back to you.

For the other analysis surface, I would recommend offsetting from the geometry. The corners of that analysis surface are overlapping with the geometry. I would recommend fixing that before using it for analysis.

will do when back in office tomorrow - thanks for the hint. But on the lamella it also doesnt work although I changed the rhino unit and adjusted gh definition based on it. Any hints? could it be from the way I extracted the faces of the geometries (using list item) and then fed them directly to analysis grid? attached is a screenshot.

If you are looking forward to checking illuminance on walls and different surfaces then it would be quicker to do an imagebased point in time illuminance and check the results in falsecolor.

This is not an error message. Just means that you have a mesh face which is not planar. Most of the time it is ok and your surface is planar based on Rhino tolerance and not the Radiance tolerance (10^-6). You can load your Radiance file back to Rhino to double check the surface.

1 Like

Please read this from the creator of Radiance