Sunlight Hours / Solar Radiation analysis on non-planar surface

Hi all,

I am trying to run a sunlight hours analysis on a non-planar surface (representing topography) but I am getting strange results with patches of black (= no sunlight hours) in random areas. Does anyone have tips for what the best way to input a non-planar analysis surface is? Thank you

Are you sure the normal is pointing to the right direction?

@eeshakhanna Please the normal direction and the grid size of the surface.

As abraham mentions above, check the face direction to be sure the points are offset from the mesh in the correct direction.

Then! Try increasing the offset distance. I often receive similar errors when the offset distance is either 1. near the tolerance of the model, or 2. Smaller than the chord length of the mesh that is generated from 3D nurbs topo surfaces.

Hi,@amjacobson Could you upload the rhino 3d model and the grasshopper file for further discussion.

@minggangyin, sure. See the attached files. The problem arises because there is an input nurbs surface that is more complex than the mesh which is actually being analyzed. Here is the input surface:

Here are a couple of screenshots to show it too. In the first case, the offset distance (_disFromBase input) is too small.

In the second case, the offset distance is large enough so that all the points are actually above the surface:

200508_test.3dm (246.7 KB) (439.2 KB)

Hi @amjacobson Here is the new result. I modified some setting of your grasshooper file. The direction of the surface is right. The reason of this wierd result is about that the grid is big and the perid is too short.
Here is the right result and the fixed grasshopper file. (438.4 KB)

@minggangyin, Thanks, but I posted the file to help explain the problem to @eeshakhanna.

Hope @eeshakhanna found this all helpful though!

Thank you @amjacobson @minggangyin, that was very helpful.
Increasing the distance from base fixed the results for me. My model is in Feet but I was using a distance from base value for meters, which is why it was too small.

I have similar issue with the ladybug v1.1.0.
I already checked the face direction and seems everything fine.
I tried everything to rebuild the mesh as mesh or brep, to reduce it, to flip faces/surfaces.

Anyone knows how to fix that issue while keeping an regular analysis grid?