Wanted to confirm / get some clarification in terms of nomenclature when writing code for LBT, topically honeybee_energy:
WindowProperty:FrameAndDivider, TestFrameAndDivider, ! Frame/Divider Name 0.05, ! Frame Width 0.04, ! Frame Outside Projection 0.03, ! Frame Inside Projection 5.0, ! Frame Conductance 1.3, ! Ratio of Frame-Edge Glass Conductance to Center-Of-Glass Conductance 0.8, ! Frame Solar Absorptance 0.8, ! Frame Visible Absorptance 0.9, ! Frame Thermal Emissivity !!!!!!!!!!!!!!!!!! DividedLite, ! Divider Type 0.03, ! Divider Width 2, ! Number of Horizontal Dividers 2, ! Number of Vertical Dividers 0.03, ! Divider Outside Projection 0.03, ! Divider Inside Projection 5.0, ! Divider Conductance 1.3, ! Ratio of Divider-Edge Glass Conductance to Center-Of-Glass Conductance 0.8, ! Divider Solar Absorptance 0.8, ! Divider Visible Absorptance 0.9, ! Divider Thermal Emissivity !!!!!!!!!!!!!!!!!! 0.7, ! Outside Reveal Solar Absorptance 0.25, ! Inside Sill Depth (m) 0.6, ! Inside Sill Solar Absorptance 0.2, ! Inside Reveal Depth (m) 0.5; ! Inside Reveal Solar Absorptance
Note the nomenclature: ‘Thermal Emissivity’
According to Gustav Kirchhoff’s law of thermal radiation, the absorptance of a medium is identical to its emissivity: the more an object can absorb electromagnetic radiation, the more it can also emit the same kind of radiation.
The absorptance of a surface can actually depend on the direction of incoming light. Therefore, one can specify a directional absorptance and a hemispherical absorptance; the latter is an average over different directions. Also, the absorptance is generally dependent on the optical wavelength.
There Is stated a Difference between Directional and Hemispherical absp/emissivity.
and in the E+ I/O reference, 'Thermal Hemispherical Emissivity is explicitly used nomenclature wise:
22.214.171.124.9 Field: Frame Thermal Hemispherical Emissivity
The thermal emissivity of the frame, assumed the same on the inside and outside.
While writing code for WindowProperty:FrameAndDivider, would utilizing the explicit nomenclature used in the E+ object be preferred over trying to maintain synchronicity with the rest of the codebase utilizing the nomenclature “Absorptance”? Or would it be preferred to utilize nomen “Absorptance” in code instead?