TT Toolbox missing components for Excel and tools

Attached Image shows what is happening to my TT Toolbox.

Issue: TT Toolbox is displaying only Colibri, Platypus, and Spectacles. Excel and TT Tools components are missing.

Problem solving to date:
I’ve uninstalled and reinstalled it, downloaded a few different versions including 1-9, 2.0.3, and the original. All from Food for Rhino.
I’ve copied the files from of the C:<Program files<Rhino 7<Plugins<Components folder and pasted it in a new folder under Owner. I’ve completely erased it from my computer and started from scratch.
I redownloaded all my Office programs (including Excel). Then tried everything again.

I have used TT Toolbox for a year and never had a problem. I’m actually still in exactly the same project, using the same script, it just is suddenly not showing the Excel and Tools components.

I’m not sure what changed on my computer for this to be happening. A new OS update from Windows… ?

Any ideas?

This is probably not the optimal forum to ask your question.
Saying that, did you unblock all files in the TT folder?
Be aware also of the new version that can be downloaded from f4R. See that Colibri comes in a separate download.

Okay, Thanks for your help. I didn’t see a forum devoted to TT Toolbox, but I’ll look elsewhere!


Maybe it is not the right place to raise this questions.
However, I will try.
I want to open a .gh file with a previous version of TT Toolbox but seems it does not exist. I tried to download an old version of this plugin but the components that appear are not the ones I had in this script.
Does anyone have an idea of where I can find the components of the 1.9.63 version of TT toolbox?

Thank you a lot!

Problem solved. I just had to unblock the zip folder when I download it from food4rhino.