Update component ladybug vs honeybee


#1

Hello,

I am wondering why some of the update_components work for ladybug but not for honeybee. Also in the ladybug output, it shows that it has updated honeybee also? How can I make sure? Thanks


#2

Hi @aorukaya,

Can you be more specific about this issue. Which components work for Ladybug but not Honeybee?

?


#3

@aorukaya ,
If you are getting an error about the SSL/TLS secure channel, see the solution posted to this discussion:

If this is not your error, please elaborate, as @mostapha said.


#4

Hi @mostapha

please see below.


#5

Can you try an alternate network? Like a mobile hotspot?


#6

Hi @aorukaya,

There are two different components involved in the process of updating.

  1. Update Honeybee and Update Ladybug components.
  2. Update File component.

The first two component update the installation on your machine. They download the user objects from GitHub and replace your current installation with the one from GitHub. There are two separate component for updating the installation one for Ladybug and one for Honeybee.

The second component updates the file based on your local installation. It updates all the Ladybug Tools component including Ladybug, Honeybee and Butterfly.

Hope it clarifies the process.


#7

Hi,
have you solve your problem? I have almost the same problem with you. It really troubles me


#8

Actually, I have tried both, and I have also tried to download and unzip the file manually form. But it seems didn’t work.


#9

Hi @547962114,
You problem seems like something @chris addressed in this post. If it is something similar to what @aorukaya metioned, I would recommend you check that Ladybug & Honeybee are getting the access to the web.


#10

Hi @devang
Maybe it’s different from what @chris addressed in this post.And the Ladybug&Honeybee are already getting access to the web.


#11

Yes.
Can you remove all the components. Restart rhino & GH. Re-install all the components and again restart Rhino & GH. If it is not about the connection to the web or security certificate then this seem like a new issue.


#12

@Siweiliu14632 ,
I see the SSL/TLS error in the output of the update honeybee component. I’m 99% sure that it’s the same issue. Follow the instructions @devang has posted and resinstal the plugins.


#13

Thank you! @chris
I have almost solved the problem with your help. even sometimes I need to restart the Rhino and grasshopper for several times, but it’s not a big problem.


#14

Hi @Siweiliu14632, One time update should solve the problem. If the update fails manually use this definition on Hydra which should update the installation with no issues.


#15

Hi @mostapha , I have successfully updated the file, but I still got the problem of " you need a new version…"


#16

Hi @Siweiliu14632,
Now, Use Ladybug_Update File component to update Ladybug tools components in a GH file.


#17

For the solve adjacency error, please try re-compute canvas.


#18

Thanks! @OmidmRashidi I have solved the problem under your advice.