URBANOpt not working after LB Versioner run

I updated LBT with Versioner yesterday and I cannot get URBANOpt to run today. In the gh interface, the error message reads:

  1. Solution exception:The URBANopt simulation failed to run.
    No results were found at:

There is no run folder appearing in the project folder.

If I run the simulation in command line I get the following response:

I have uninstalled and reinstalled URBANOpt with no resolution. I tried to bundle install and the installation fails as shown:

I am not sure what to do now, but it all started with a versioner update. I have also tried reverting to 1.4.1 without any luck. I have noticed people with similar problems in the last month, but they seem to have found a resolution with URBANOpt. I have not.

1 Like

I encountered same error too.
Urbanopt is not working in all of the platforms I have(mac and windows)

In addition, the when I run the sh file manually, it says like this

I really don’t know what to do. It ran well last night but suddenly stopped working.

1 Like

Thank you for the update @Junoh. It is probably not LBT then. I hope I did not do more harm than good trying to fix the interface. Unfortunately, I am supposed to have a production model done by Monday. Oops.

I found a reason. It was because sometimes it is not working with .bundles folder.
Nothing is in the .bundle/install/ruby/2.7.0 folder.
The problem is… I don’t know how to solve this…

I cannot find this particular path on my machine. There is a .bundle folder but it does not contain an install folder.

that is why you and I are having issue. There should be something inside of the folder.

I wonder what has suddenly changed.

Any resolution on this for you @Junoh ? I have not figured it out.

I solved this issue with very rough way.
I just deleted .bundles folder and rerun the simulation part.:joy:

What path is this .bundle folder on for you? @mostapha are other people reporting this problem after 1.4.3? I cannot find any version of LBT to run URBANOpt right now.

There is a problem with some bundler conflicts for URBANOpt CLI. I went back and deleted an old version of OSS, downgraded to 1.4.0 LBT, uninstalled URBANOpt CLI and reinstalled. Now the CLI is running again.

Sorry for the late reply and thank you bother for getting to the bottom of this. It seems something has changed in URBANopt’s dependencies that triggers this issue. I will try to recreate it when get home and see if I can push a fix.

Hey @Geo_curious ,

I’m not able to recreate the issue on my end and I have no issues running things with the latest URBANopt and Ladybug Tools (via the versioner).

If you are re-using an URBANopt project folder, which had previously been created with an old version of Ladybug Tools and URBANopt, the .bunlde folder in the project folder could be out of date and manually deleting it should get things to run smoothly again.

1 Like

It worked when I changed the name (DF model )


Dear Chris… I think DF model component has a bug… Becuase If I want to run Urban OPT component I have to change the name of DF model component… Maybe you can check the deatil of that compenet.