UTCI Map failing on Longwave MRT step

I kept having this createLongWaveMrtMap error on the latest version using the template script with custom geometry, does it happen to anyone before?

It’s tough to know what’s up if we cannot recreate the error. Do you have a minimal sample file that recreates the problem?

Hi, @Di and @chris,
I encountered the same problem yesterday with the latest version of LBT.
When I add the transmittance schedules of the tree units and an additional schedule to the UTCI map like in the example .gh file for the time period of an extreme hot week, I get the same Runtime error.

This morning I ran the script without schedules and it worked, so I suppose it would have something to do with them.

Here is a screenshot of the schedules I used (it is still a bit unclear to me how I should integrate them with correct inputs, so that they align with each other, so I would be happy about some guidance and feedback! :slight_smile: )

Kind regards,

Hm. I still cannot recreate the error using the latest development version of the plugin and the sample file at the link you posted:

Can someone post the log file of a failing simulation that should be at:


That will let me know exactly what went wrong on your machines.

Hi @chris,

Please find an attached log file below:

logs.log (757.5 KB)

1 Like

Thanks, @lorabo ,

I can see from the log that the main problem is a failure of the EnergyPlus simulation:

Can you try simulating your Model in OpenStudio/EnergyPlus with the HB Model to OSM component and let me know what the exact failure message is?

It appears that EnergyPlus is just crashing without warning in the log files and maybe there’s more info in the EnergyPlus .err file that gets parsed with the simulation failure of the Model to OSM component.

Thank you for the quick reply, @chris
I just ran the simulation with the HB Model to OSM component and I didn’t get any failure message with the tree transmittance schedule or the run period (for an extreme hot week; _timestep = 1).

I ran the UTCI simulation also without the UTCI schedule (screenshots below) and got the same error message like before (failed to create Long- and Shortwave MRT Map)


Hi @lorabo ,

Can you run the “Model to OSM” component without those simulation parameters?

I think those parameters there could be interfering with me seeing the real EnergyPlus error that’s happening on your system.

If disconnecting the simulation parameters does not create the error on the “Model To OSM” component, then I can also try one other thing that could help me recreate the issue. Can you upload the idf file that the UTCI recipe produces here?