Value cannot be null. Parameter name:Source

Hi All,

I am not able to make an error go away. Please find the picture below.

I have done everything Mostapha recommends on this post.

There are a few other post related to this one and I have gone through them as well.

I have tried preparing my geometry a couple of different ways.

I have tried running this file on a colleague’s machine.

In all of the above cases, I have been unsuccessful in finding a remedy to this problem.

I would really appreciate is someone can look into this one please.

-Devang (624 KB)

Hi Devang,

I get a look at your file and … it is working for me as is.

Though a needed to set the path for LB_LB and HB_HB. Since to be that the last update force that the default is now at the …/Roaming/… location and not also at C:\Ladybug (as both of them were allowed before). After that it worked fine.

I would check, anyways, also the tolerance of Rhino (mine is 0.001). Not sure this can be, but please check.

If nothing of this helps, test the component to identify the code line where the error is happenning. This can be helpful for debuging.

Attached the file that i “touched”.

-A. (651 KB)

Thank you Abraham for looking into this one.

I expected that this would work on someone else’s machine. My guess is, this is not a LB+HB issue. If I supply a different geometry (A few Zones), it works at my end as well.

My rhino tolerance is the same. I did not fully understand your comment on default folder path. Can you please elaborate on that? I have a latest version of LB+HB that works without providing any file paths.



Hi Devang,

See the input of both LB and HB for setting the defaultFolder. I set it to c:\ladybug.

But i understand now is not your problem since the file works for different geometries (in my case it complained about schedules missing). Can’t thing what can be wrong if sometimes it works and sometimes it doesn’t.