Vectors not generated


I have tried to run the example file 01_0_outdoor_airflow , while following the instruction video on youtube. All goes fine, until the solution. It seems like no vectors are generated. Therefore also no wind visualisation occur. Ux, Uv and Uz remains 0 during the loop in OpenFoam. Why can this be?

Hard to say with the information you provided.
Also, will you be interested in updating to the latest version of Butterfly? That way a lot of us can actually open and run your file. If yes, you can please check this

Thank you for your reply!

I have now downloaded the latest version, and I tried to run the newest example-file, which I found in this forum. I do nothing with the setup, and my rhino-file is in meters. Still no vectors are generated. The U-folder looks the same for 0 iterations and 600 iterations - and the screen looks like the screen shot above.

May it be that some input get lost in the download? I have tried to search through the document for it, but do not know what it could be.

By the way I tried the indoor simulation as well - when I had the older version installed, and that is working fine, so I dont think this has anything to do with OpenFoam.

The example file I used is attached here.
Thank you for helping me out with this! (445.6 KB)

Also, now, in the newest version, the snappyhexmesh dont work - it do not generate any mesh. I understand it tells me to “add surfaceFeatureExtract to case command list”. But how?

If you have updated the butterfly installation, then you need to update the components on the grasshopper canvas as well. In the file you attached, the components are of the old version of butterfly. Please use the attached sample file (506.7 KB)

Thank you. I ran that file, but the same problem with no vector occurs. Also in that file, it seems like the snappyhexmesh dont work - it is no difference between the mesh visualised from that component, and the one generated by the blockmesh. The biggest problem is still though that no visualisation appear of the airflow.

I also get the same result after trying this on two different pc´s, so I guess there must be something with the file? (508.6 KB)

I am using the latest version of butterfly with OpenFOAM 1612. The file is running totally fine at my end. Below is an image from an evolving solution.

Can you please share the exact error happening at the snappyhexmesh component?

1 Like

I am using OpenFoam v1806, but I have updated the scrips so that it works with Butterfly according to this:

For the version of Butterfly available through Food4Rhino, I get the indoor airflow simulation to work, and the outdoor airflow seem to work until the solution-part - where all the vectors come out as 0.0.0.

For the newest version of Butterfly, I get neither to work. For det indoor airflow simulation (the example file in the newest Butterfly folder) the process stops with the meshing not happening, but the component says nothing about any error.

In the outdoor airflow simulation you sent me, the snappyhexmesh works now, for some reason. But the vectors still come out as 0.0.0. So the same happens as with the old version. The mesh recolours all blue. When I turn on VectorDisplay from the WindVector component with anchors to the GenTestPts component, it seems like the basis for the vector data should be there, and all the components run in OpenFoam without any errors.

Of course the values should come out like this, like it does for me in the older version of indoor airflow simulation.

Any ideas?

I figured a way around this problem, by working with the interior-airflow setup and modifying it to run and visualize a simulation around volumes. But still it would be nice to know whats the problem that causes the vectors to come out as 0,0,0, if anybody has any ideas.