Visualize from HB Hive problem

#1

Hi @mostapha and @chris,
I get in to this one today: I’m separating HB zones by program. The i define windows for each zone according to their program (see blue groups in attached) At the end of the process i want to vizualize the resulting zones with their windows with the HB_decomposeByType component. And here is when the issue appears. The component fails with the followinf error:
Runtime error (KeyNotFoundException): 330db659-0689-4344-ba17-d91a9c08efc0

Traceback:
line 8474, in visualizeFromHoneybeeHive, “”
line 103, in main, “”
line 161, in script

Connecting separately the zones by program seems to work. But when i connect all of them together it fails. It is not that the results is not there. When i see the resulting geometry with the wireframe component everything is there.


My assumption is that something is messed up in the process of separating the zones.
This goes beyond my capabilities to deal with such error types.

Looking inside the clusters show that the geometry is created fine. Need to say also that sometimes i need to recalculate (disable/enable) the cluster component in order for it to work.

I’l appreciate your help on this one. I expected this process to work flawless … and here i am

Thanks,
-A.

Visualize from HB Hive Bug_Problem.gh (698.7 KB)

#2

Hi @AbrahamYezioro,

KeyError happens when an item id is missing from honeybee-hive. This happens in rare cases when one copy-paste components from one document to another. Re-calculating the script should solve this problem in most cases. Have you tried that?

#3

Hi @mostapha,
Many … many times.
I copied-pasted the cluster in the same document. Each cluster gives the proper result, but joining the results of all fails.
-A.

#4

OK,
I exploded one of the clusters and it is working now.
Somehow probably in the process of creating the windows inside of them they gave the same ID to one/more objects.
I redefined the clusters independently, instead of copying one of them (even though they are identical).
So, unless there are some wisdom words regarding the use of clusters, the issue is solved.

Thanks for the hint @mostapha.
-A.