Warming up days - open studio/energy plus

energyplus
openstudio
#1

Hi,

I’m trying to run an energy simulation in a cold climate and the default number of warm up days (25) is not enough. I am using the simulation control component to increase this, (see the old thread below) but when I go into open studio it still ends at 25.

If anyone has any ideas for how to get around this that would be great.

Many thanks,

Aimee

The old thread with the component and file I used:

#2

Hi @Aimee ,

Welcome to the forum! It seems the reason why it does not work is because the Building object in OpenStudio SDK does not have the maximum number of warmup days exposed on it:
https://openstudio-sdk-documentation.s3.amazonaws.com/cpp/OpenStudio-2.8.0-doc/model/html/classopenstudio_1_1model_1_1_building.html

You can see that it is on the equivalent EnergyPlus object here: https://bigladdersoftware.com/epx/docs/9-0/input-output-reference/group-simulation-parameters.html#field-maximum-number-of-warmup-days

We are currently working with the OpenStudio development team and I will ask about exposing this property the next time that we talk. In the meantime, I’m sorry that I can’t offer anything better than the following options:

  1. Use the direct E+ exporter in Honeybee (and sacrifice detailed HVAC systems)
  2. Use an EnergyPlus measure to automatically edit this property after export from OpenStudio
  3. Manually edit the number of warmup days in the IDF and use the ReRun IDF component to run it through E+ and bring the results back into Grasshopper

Also, I don’t see a warning about convergence in your screenshot. Is there something that I am missing?

#3

Hi Chris,

Thank you, I’ve managed to update the warm up days but unfortunately it does not converge even after 500 days! So I think I have a much larger error elsewhere. I will go back through the rest of the script and try to identify it :slight_smile:

Yes you’re right the screenshot doesn’t show a warning. The script I was using wasn’t all my work so I screenshotted a sample to show the component I was having trouble with.

Thanks again,

Aimee

#4

@Aimee ,

I should also mention that, sometimes, the lack of convergence isn’t necessarily erroneous or incorrect if the type of things going on in the building are intentionally dynamic. For example, I know some of simulations that I have run with natural ventilation don’t converge but this is because the windows keep opening and closing in response to the zone temperature. In this case, I tend to just note the warning but proceed with analyzing the results.

#5

Hi,@Aimee
I suggest you upload your grasshooper definition for further discussion.