Why do I get an error about "the download failed" when installing with the Food4Rhino installer

Hi, this is great!
Is that can be solved in rhino 8?

I had in rhino 7 and updated it. after that I use the uninstaller to clean and open new rhino 8 grasshopper it comes with an error :frowning:

p.s: I disabled the firewall and tried different network… every time faced to this.

Hey @hdimor.mr ,

This issue doesn’t appear to be related to Rhino 7 vs Rhino 8 since I have no issues running the installer in either Rhino 7 or Rhino 8 and no one else has reported any issues:

The issue seems to be that you had an existing installation and that the uninstaller.gh did not run properly. This is why the message says that a ladybug_tools folder already exists. Can you manually delete this folder?

It’s also very odd that you seem to have a blank user name. Am I right that you just blanked it out of the message in order to not share that info on the forums? Or is there actually a blank username on your machine?

I blanked it out myself. The user name is okay there is no special character or any white space used. apologize for that.

It will generate an empty Ladybug folder when I delete that and hit True.
and it gives me the same error.

Good to know that you just blanked it out yourself. And it seems that, at least for your new screenshot, the issue is not that the uninstallation process failed.

That just leaves the likely explanation as the permissions you have on Rhino 8 don’t seem to be what you had on your old Rhino 7 installation. Can you run Rhino 8 as administrator and then try running the installer.gh?

If that does not address it or you can’t do this, I’ll just have to direct you to use the free Pollination single-click installer in order to install Ladybug Tools 1.8.

1 Like

Thank you, when I want to log in into pollination with google neither with email to get the installer I encounter to network issue message on website.
That’s my another issue.

It sounds like you just have a lot of restrictions that have been imposed on what you can download to your machine. Is this your personal machine or is it one that is governed by IT overlords?

Hi, I had a similar error. This is not the standard way, but it worked for me. I ran Rhino 8 as an administrator, and the installer didn’t work again. Then I opened the V 1.3 installer in Rhino 8, and it installed successfully! As far as you know, V 1.3 was for Rhino 7 and 6. Then I reopened Rhino 8 and the LB_T 1.8 installer and finally installed it successfully.

Like @chris suggested, try open Rhino as administrator it’ll hopefully address the issue.

It’s my personal computer

This error occurs when I install rhino version 8, before I install version 8, I uninstall and install lbt 1.5 device along with radiance, open studio. Previously in the rhino 7 version, lBT 1.5 can be installed. After that I went back to rhino 7 to reinstall lBT 1.5, in fact the same error occurred

How to solve the problem @chris

Thank u

@adenurmap , did you tried out first uninstalling using uninstaller.gh and close and open rhino as administrator and open and run installer.gh again while firewall is set to off?

If it doesn’t address the issue you can try installing older version first might help.
Or try this:


1 Like

I’m a little bit at a loss to know exactly what’s happening here since I can’t recreate the issue on my end. But, building off of what @OmidmRashidi said, I have a theory. The newer LBT 1.8 plugin installer is trying to download a .zip file of Python 3.10 from our google cloud server:

The older LBT 1.3 was downloading a .zip file of Python 3.7 from our old Digital Ocean server:

I can’t remember exactly what our DigitalOcean account was using on the back end but it might have been AWS instead of Google.

So my question would be, do you live in a place where your access to Google might be blocked? That could also potentially explain why @hdimor.mr had a hard time reaching the Pollination website. If this is the case, then the best suggestion that I could make would be to use a VPN to get around this restriction. And, if you have the option, the Pollination installer is generally going to be better than trying to use the Food4Rhino installer since everything is self-contained within the Pollination installer but the Food4Rhino installation pathway relies on downloading all sorts of different things from different domains across the web.

Hello @chris thanks for explanatory comments.
I think the blocking from accessing is the problem too. Even when I change my IP with some apps the issue still persist. only once I was able to reach pollination to get the installer and successfully installed. I couldn’t able login to pollination grasshopper anymore.