Windows 10 Install error - OpenFoam

Hi Folks

Looking for help installing OpenFoam so it runs on a Windows 10 machine.

Have installed the butterfly/OpenFoam combo on my machine at work - Windows 7, with no real problem. Followed procedure here:

This I found by following the instructions here:…


At home here on my newer, faster Windows 10 machine - no such luck. This is becoming quite frustrating as I feel I am failing some obscure intelligence test.

I have attached what I suspect is the likely problem identifier - not that it has helped me identify the fix. What I believe is the salient message is appears in the OF_Env_Create Powershell Window (Running as Administrator) , which is step 3 on the Windows 10 special instructions found here:…

The message (in red as can be seen in the attached picture) states:

Set-ExecutionPolicy : Windows PowerShell updated your execution policy successfully, but the setting is overridden by a policy defined at a more specific scope. Due to the override, your shell will retain its current effective execution policy of “Unrestricted”. Type “Get-ExecutionPolicy -List” to view your execution policy settings. For more information , please see “Get-Help Set-ExecutionPolicy.”
At C:\Users\Michael\AppData\Local\Temp\Quest Software\PowerGUI\18d7ce54-562c-4f2b-b985-3c24b83cae50\of_create_container.ps1:1 char:20
+ Set-ExecutionPolicy bypass
+ CategoryInfo : PermissionDenied: (:slight_smile: [Set-ExecutionPolicy], SecurityException
+ FullyQualifiedErrorId : ExecutionPolicyOverride,Microsoft.PowerShell.Commands.SetExecutionPolicyCommand


Hi Michael,

This error doesn’t necessary is an issue in running OpenFOAM and butterfly. What happens when you run the batch files?


Hi Mostapha

I had tried running the batch files - with limited success. And had uninstalled and reinstalled all Saturday a couple of weekends ago. Now this weekend I did ONE thing different and I seem to have a functioning Open Foam on Win 10. I ran the OpenFoam installer as Administrator. I had been running everything else as administrator. The illustrated picture is still an accurate picture of what happens at the start of the Open_Foam_Create powershell script…

However, now running OF start and then Rhino/Grasshopper has a primitive script operating. Next step: create a GH operation that finds all the polygons in a GIS file, builds a grid of point over the refinement region at 1.5m from the terrain and extracts from the grid list all the points inside of or coincident with these GIS polygons…

Thanks again for your assistance. It was watching the youtube video again that triggered the ‘did I run the OF installer as administrator?’ doubt leading to the latest clean install