WindowsError in Run radiance component

Hello,

I don’t know why, but I’m facing the following error on the Run Radiance component in Honeybee +

I have all the LB/HB legacy and HB+ components updated. I’m running Radiance V5.2.1, OpenStudio 2.9.0, and DaySim V.4.0.0

@sreejithjayaram93 Above info is less to understand what’s the error. Please share the Gh script for better understanding.

sorry… usually I do include my files.

Here you go… Test_8.rar (933.9 KB)
I have attached the Rhino file, GH file and the BSDF’s

@sreejithjayaram93 It worked fine on my end. Have you tried updating the + library?


I am reattaching the working file.test_8.3dm (145.3 KB) test_8.gh (537.8 KB)

I don’t know why this is happening… I have updated all the libraries and also replaced the scripts in the rhino folder… It doesn’t seem to be working… I’m running into the same error…

@sreejithjayaram93 I saw your using radiance 5.2.1. Try updating radiance to 5.2.2 from here

I tried updating Radiance by downloading the asset from under the radiance 5.2.2, uninstalled the older version, installed the newer version, copied falsecolor2.exe. Still the Version seems to be 5.2.1. and of course the the same error appears.
I connected the honeybee fly panel to a panel and it seems to be working fine. Not sure what I’m doing wrong here.

I wonder if this is a permissions issue. Can you try both of these things and see if you are still getting the error?

  1. Move your project folder from the E drive to somewhere else, preferably your desktop folder on the C drive.
  2. or, Try running Rhino as Admin. You should be able to do this by right clicking and then selecting run as administrator.

Regards,
Sarith

2 Likes

Hi Sarith,

I tried what you told me… Moved it to the desktop opened the files as administrator. But I get the same error.
Runtime error (Win32Exception): WindowsError

This is the error I recieve.

Traceback:
line 435, in init, “C:\Program Files\Rhino 6\Plug-ins\IronPython\Lib\subprocess.py”
line 176, in call, “C:\Program Files\Rhino 6\Plug-ins\IronPython\Lib\subprocess.py”
line 237, in run, “C:\Users\Sreejit Jayaram\AppData\Roaming\McNeel\Rhinoceros\6.0\scripts\honeybee\radiance\recipe_recipebase.py”
line 65, in script

Does your folder path still have spaces in it? In the screenshot that you posted initially, there are
spaces in the folder path(“04 Semester”).

1 Like

The spaces were present previously when the project was in the E: Drive.
The issue persists when it was copied to the desktop (maybe because I have a space in my username).

Okay, So I was able to fix the issue. So, I copied the file to my C: Drive and then to the properties of the Rhino File and there was an option which said Unblock in the attributes section of the file. After which I re-launched Rhino+GH.

Thanks Sarith for your help! :smiley:

Hi!
I am having this same error but with HB 1.1
I followed the steps in this post but still doesn’t work.

In the output message of the HB Run Recipe sais:
0. Runtime error (Win32Exception): WindowsError
Traceback:
line 439, in init, “C:\Program Files\Rhino 7\Plug-ins\IronPython\Lib\subprocess.py”
line 132, in script

Do you have any idea? :slight_smile:
Kindly
MarcotrialDL.gh (53.6 KB)

hey there!
could you find the solution? i have the exact same problem