1.2 HB Outdoor UTCI Comfort Map error (on Mac)

Hello LB community,
I am trying to run Hb UTCI Comfort Map in outdoors, with trees and materials assigned for different surfaces. I am getting the ‘invalid result folder’ error. This was my initial idea (after checking the discourses here on outdoor thermal comfort map) :
1.Use UWG to create an epw (although I am not sure if the ddy file necessary for UTCIMap would match with this)
2.Create hb faces with different material properties (grass, water, concrete)
3.Put these faces in HB model, where the buildings and trees are the shade inputs

I get this error:

As written in the topic, I use Mac (Rhino 7 and LBT 1.2). I attach the gh file and the model via drive, as I am a new user here. Thank you in advance for any comments and help. And THANK YOU for developing these tools so I can use them on Mac! But if I need a pc to be able to run this sim, I can do that too :’)


I will try to take a look when I get the chance, @Ege . If you are not getting the same error on both Mac and Windows, this is definitely a bug.

In the meantime, if you wouldn’t mind running your model using the latest development version of the plugin, I implemented much more explicit error reporting so that we can see exactly where the recipe failed.

You can install the latest development version by running the “LB Versioner”, restarting Rhino/Grasshopper, and then using the “LB Sync Grasshopper File” component on your .gh definition.

Thank you very much for your reply Chris.
Here is the detailed error report below. (I guess it is not a bug but instead my mistakes?)

To get the full report I also connected HB Recipe Settings (gave a name to the folder and set report_out to True), but I got another error like this:
0 Failed to create folder: napoli1
[Errno 30] Read-only file system

1 Failed to create folder: napoli1
[Errno 30] Read-only file system
Runtime error (MissingMemberException): ‘module’ object has no attribute ‘SameFileError’

2 line 199, in write_inputs_json, “/Users/cakalege/Library/Application Support/Mcneel/Rhinoceros/7.0/scripts/lbt_recipes/recipe.py”

line 272, in run, “/Users/cakalege/Library/Application Support/Mcneel/Rhinoceros/7.0/scripts/lbt_recipes/recipe.py”

line 148, in script"

@Ege ,

I got the chance to check you model and it’s definitely a modeling issue. You need to have Rooms in your Model to use any of the comfort mapping workflows since you can’t run an energy simulation without Rooms. You made a model that only has Faces and Shades:

I’ll try to make the error reporting better for this case.

Thank you again for the reply. Yes I also realised this when I checked the definitions more carefully :sweat_smile: I will come with a working script soon hopefuly, starting by creating rooms as grounds.