1. length of the results [=1] is not equal to the number of mesh faces [=153] or mesh vertices[=180]

Hi Mentors…
I have read all the related problems resolved discussed in the forum… but none of it works for me…
I have done the same daylight simulation using this GH file before and it works fine. I tried again using the exact same rhino file, recreate a new surface to reassign as the “test surface”, the errors then occurs!
But every other settings remains the same, I cannot understand what is causing this error.
I have tried the following but still facing the error:

  1. Set to meters
  2. flatten the result
  3. not setting any north
  4. mesh join
    Appreciate any help! Thanks!!

Internalised GH file attached:
DLG_TGPS(internal).gh (1.0 MB)

Can’t check your file but from the image i see that you are connecting the joined mesh to the results and probably the results to the inputMesh.

-A.

Hi, @AbrahamYezioro … thanks for your response. I also tried removing the mjoin, it still did not work

You don’t need to remove the mjoin. But you need to run the annualDaylight component. From the image above you didn’t.Sorry if it sounds to obvious.
-A.

@AbrahamYezioro i did simulate it n my computer hang umpteen times… i tried reinstalling rhino n radiance over the weekend… n rerun it … its working fine now though the same warning message still appears… thanks anyway!!

Hi @Joey_L , since it is a multi-zone Daylight simulation.
I guess you are trying to achieve the DL results for all the zones with a single legend.
In that case, you need to

  1. FLATTEN THE RESULTS and attach them to the recolor component - analysis result section
  2. FLATTEN THE MESH AND THEN JOIN THE MESH and attach them to the recolor component - input mesh section.

Read this discussion for more clarity.
https://discourse.ladybug.tools/t/one-legend-for-multiple-zones-in-daylighting-simulation/1537/10

And,
Your model looks messy, it is better you use Honeybee_CreateHBZones before you connect it to the simulation.
I believe you are not doing it because your model is not creating a closed volume and is throwing you a warning.

1 Like

Well, for the sake of the test i tried your file above (it is just one room to check). i connected the right inputs and it shows the results without any complaints, like so:


And here is the file.
DLG_TGPS(internal)_AY.gh (1.1 MB)

Your setting for the radiance simulations are a bit high so it takes some time to calculate.
-A.

I guessed i am not clear in my explaination. Aplogise for that. Yes actually after i managed to simulate it, the message was gone too (as what you have shown).

Hi @maheshjayayachander . Thanks for your pointers! I will test them out for the legend. I also will read up and learn how to do it in hbzones as i am not too familiar with that command. And yes, you are right, the model is not closed …