A problem of "1. Solution exception:There must be at least 3 vertices for a Face3D hole. Got 2"


I have had a problem when a quite complex geometry is assigned to one script given as a sample. I thought that this page could help, but I have not been able to solve it (LBT 1.0.9 Sample file error).
I have attached two images of the information of the model and what the red component has said.
I was just wondering how this problem could be solved.
Thank you

1 Like

You might want to try dropping your unit tolernace in rhino. If that does not work, can you please share this goemetry?

@devang is correct. One of your faces is so small that it’s invalid within the Rhino model tolerance. Either make your model tolerance smaller or replace the small invalid surface with a valid one.

Thank you very much for the responses.

Decreasing unit tolerance and “internalize data” have not been able to work, unfortunately.

I was just wondering how you had found the number of the invalid surfaces had been one. Could the geometry have more than one invalid surface? Have we had any commands to find such a small surface?

Thank you


I have simplified the geometry by decreasing the number of the surfaces. The geometry has been closed, but I have got another sign, as the image shows.
Did anyone have any ideas of this matter?

Thank you

It would help if you could share the geometry. Otherwise, try dropping unit tolerance even further. There’s a face in your geometry that has an edge with a length smaller than the unit tolerance. Until the unit tolerance is not made smaller than that edge length the issue is likely to persist.

Thank you for the response.

I have changed “model units” from “Centimeters” to “Millimeters” and I have changed absolute tolerance to 0.000001. The script has seemed to be half working, but the last component has shown a red warning, as the image shows.

I have not been able to internalise the data of the geometry, again.

Thank you


i had a similar problem that occurs, i assume if ratio width/height is too unfortunatelly.
I therefor put a try: / except: arround the geometry export (line 104, 126, 127)

The err_geo returns the failed geometries for further analysing or deletion.

Best regards,

1 Like

Interesting idea. Maybe we should add a component that helps QAQC the bad geometries that are not valid in the Rhino model tolerance. Technically, the only part of the code that you need a try/except around is the to_face3d(geo).

1 Like

Hi Chris, I am finding the same issue when I try to make trees from Archicad into shade elements in Rhino. Because there a many small faces the Rhino model tolerance goes crazy. I have the computing power to do the daylight exercise but the coding of the Ladybug Shade component prevents me from doing it.

@chris, I was just wondering if you ever progressed the idea to add a component to help QAQC geometry and identify bad geometry. I frequently get the “Preview the output Room to see the holes in your model” error, though it is not clear how I should “preview the output room”?

Hi @chris and @devang,
I faced a similar issue, and it was not resolved no matter how much I decrease the tolerance,
Do you have any other suggestions?
I attached the problematic part of the model,

There must be at least 3 vertices for a Face3D boundary Got 2.gh (576.8 KB)

I had a similar problem too. I dropped the tolerance but it didn’t work. This error disappeared when I connected the geometry as a mesh brep. It might work for some situations. Good luck

1 Like

Hi @Nimafo,

Opening your script I get no errors.

These are my unit settings

There’s a backlog of stuff here I forgot to respond to.

Yes, we added a component for this and it was in the last stable release. It’s called HB Validate Model and it gives a full report of everything that is invalid about a model, which could cause it to be un-simulate-able. The Pollination Rhino plugin has an even nicer UI for this capability, in which can zoom to each invalid geometry and fix it really quickly, though I should note the Pollination Rhino plugin is paid since the UI is mostly a time saving feature. If you have enough time and expertise to parse the validation report from the component, you can eventually achieve the same level of QAQC. FYI, all of the components under the 1:: Visualize tab can help you “Preview the output Room,” and this also can help with QAQC.

Decreasing the tolerance to @charlie.brooker 's settings seems like it’s one way to resolve this. I also recently pushed a change that will still enable things to run with these geometries at coarser tolerances. Also, if you really want to include these highly detailed geometries in your studies, I recommend meshing them first like so:

1 Like

Hi, I am having a similar problem when trying to do the spatial heat map analysis (looking into outdoor comfort using ladybug). At first I thought it was because I was trying to map out data for an entire week but even when I changed it to a day it didn’t work.

here is my geometry, thanks in advance!

and this is the error

Hi @barnd791, this looks like it’s probably a different issue - what’s the error message when you press the red bubble?

I’d guess that the number of values doesn’t match the number of mesh faces

hi! I actually figured it out, it turns out I did have to the run the stimulation for an hour on a day rather than for an entire week!