LBT 1.0.9 Sample file error

Hi @chris,

I’m having difficulty to test the LBT 1.0.9 version, specifically the example file from the honeybee-energy samples. (attached). I started by opening the samples and I cannot get this one to work.

At first I was getting the “Applying Measures Failed. Check run.log” error, which was solved as you described in this post (I also had the units in Millimetres):

Now I’m getting this message, that I cannot figure out how to solve:

  1. Solution exception:There must be at least 3 vertices for a Face3D boundary. Got 2

The full report text:

Runtime error (AssertionException): There must be at least 3 vertices for a Face3D boundary. Got 2
line 1643, in _check_vertices_input, “C:\Users\fb\ladybug_tools\python\Lib\site-packages\ladybug_geometry\geometry3d\”
line 620, in remove_colinear_vertices_envelope, “C:\Users\fb\ladybug_tools\python\Lib\site-packages\honeybee\”
line 87, in init, “C:\Users\fb\ladybug_tools\python\Lib\site-packages\ladybug_geometry\geometry3d\”
line 714, in remove_colinear_vertices, “C:\Users\fb\ladybug_tools\python\Lib\site-packages\ladybug_geometry\geometry3d\”
line 963, in remove_colinear_vertices, “C:\Users\fb\ladybug_tools\python\Lib\site-packages\honeybee\”
line 179, in script

I tried troubleshooting the initial geometry by baking the internalized inputs to Rhino, but neither did SelSmall, SelLine, SelBadObjects return any result to filter out the degenerate face.

Is there a way to filter the model to find these objects? How should I approach this problem? What could be causing this?

My LBT install looks like this:

The builds differ to yours in the Github Wiki, but I downloaded them today, I guess that’s why (the point releases are the same, matching the Compatibility Matrix).


(The GH file is the one downloaded from Food4Rhino, from the LadybugTools 1.0.9 Sample folder). (416.6 KB)

@furtonb ,

I have been able to run the file you attached without issues after using the “LB Sync Grasshopper File” component in order to sync all of the components on the canvass with the latest version that I have installed.

I think the likely reason why you are getting that error is because you are using that sample file with a Rhino model that’s not in Meters. The input geometry of that sample file is all in meters and, if your Rhino model is in some other units system like Millimeters, the building surfaces will be extremely small. So small that, in your case, vertices are too close together that they are considered to be equal within the Rhino model tolerance and are removed to make invalid surfaces.

So you should change your Rhino model to meters and then open the updated sample file. (420.1 KB)
Then you should have no issues.

Hi @chris,

I tried running the updated file, I’m getting a different error now:

  1. Runtime error (ImportException):
    Failed to import honeybee_energy:
    cannot import osw from honeybee_energy.result

line 105, in script

Any suggestions?
The Rhino model is in Meters. I opened a new file from the template “Large objects - Meters”.

I noticed I have the ModelToOSM component v1.0.0 in the file I uploaded, you have 1.0.2.

My version of that component is 1.0.0, when I drop a new instance to the canvas.

I ran the LB Versioner component which updated my installed ModelToOSM to 1.0.2 too.
Now the definition returns the same results as your screenshot (assumed by eyeballing). :slight_smile:

1 Like

Hi there @furtonb ,

I get a similar error “1. Solution exception:There must be at least 3 vertices for a Face3D boundary. Got 0”. but I could not fix it with the solutions mentioned above (eg. my units are in meters, I tried to use baked geometry and I also updated my versions with the LB versioner).
The same error remains on the ModeltoOSN component

I could not find the problem in my geometry model. Any suggestion how to investigate what room could cause the problem? Thank you! (924.6 KB)

Does anyone have any suggestions? I worked on it all weekend but I could not figure out what is wrong with the geometry :frowning:
Thank you!!

hi @mkdg,

Sorry, I saw your message briefly last week… I’m having my final thesis presentation this week, I won’t be able to check your file before that.

1 Like

I made some tests and think i isolated the faulty geometries. Though no advice how to fix them. Maybe instead of having an apex i’ll put there a small polygon with the number of sides of the base.
See attached the red group having those geometries.

-A. (929.0 KB)

1 Like

Thank you I had a look, you were right something was wrong with the corridor towers!
The problem occurred not with the tower itself but when assigning windows to then (the shape of the apertures was not accepted by the energy model).