Accelerad 0.7 + Ladybug Tools 1.2

Hey there,

I am trying to use Accelerad 0.7 + ladybug Tools 1.2 for calculating annual daylight (Rhino 6). I used the example file provided within Ladybug Tools installation files. I managed to run analysis with the latest Radiance release - Radiance 5.4a (2021-03-28). I also tried one which is presented in “compatibility matrix”, but had some errors like “Invalid exception: invalid resource folder”, described here Is it possible to get LBT 1.2.0 working with Accelerad? - #9 by chris.

I instaled Accelerad as described in their documentation (switched Radiance files for those provided by Accelerad) and everything seems to work ok, but I see in the logs that Honeybee/Radiance still uses CPU - it looks like the Accelerad reverts to basic Radiance CPU behaviour. Does anybody knows how to make it to use GPU?

My computer should work with the GPU support (RTX 2060). In addition, I used old Honeybee+ 0.0.06 release to do similar thing (used annual_daylight_gridbased example file, using the same Radiance/Accelerad installation) and the logs clearly showed the Accelerad GPU usage. The problem with Honeybee+ is it uses only single CPU for preparing the scene.

Problem solved. As a reference for somebody with similar issue:
I’ve made the update of Ladybug Tools for the latest dev version (1.2.49) and the logs started to show the Accelerad GPU usage. The computation times didn’t change so I assume it’s always used GPU, but v. 1.2.0 didn’t show that info in logs.

1 Like

Did you overwrite the correct files?

LBT is using C:/users//ladybug_tools/radiance
HB Legacy is using C:/radiance

I’m assuming I need to change the names of the accelerad dlls and such to match their normalrad counterpart?

You’re right. If you need it in LBT you need to overwrite the LBT normalrad files. Have in mind that you need to parse -g 0 (if I recall correctly) in order to bypass and have accelerad behave like normalrad. The G parameter cannot be parsed in Honeybee legacy and will be ignored. Unsure with LBT.

1 Like

Awesome! thank you
I have a model I’m intending to experiment with the whole VR radiance reporting :smiley: mildly very excited

updated to correct -g 0 parameter, see more here

1 Like