An URBANopt installation was found at C:\URBANopt-cli-0.8.0 but the URBANopt executable is not accessible

Yes, the Rhino version is just there for reference and it’s not required that you match that version of Rhino with the version of Ladybug Tools or the engines.

Just make sure that you’re matching the Ladybug Tools version with the simulation egines.

Unfortunately, it didn’t work. But there is a strange thing happened with me, I was running the env_uo.bat using the cmd to put the error here and then I found its showing 0.8.0, Despite I uninstalled it and installed 0.8.2

Hey @Mohammad.ElGhandour ,

You’re almost there. It looks like you just overwrote the file at C:\Users\[USERNAME]\.env_uo.bat to be something that’s referencing the old installation of URBANopt. This should have automatically been overwritten when you drop a Dragonfly component on the canvass. Maybe you overwrote it after you had opened your Grasshopper file? In any event, if you use the following file in C:\Users\[USERNAME]\.env_uo.bat, it should all work correctly:

env_uo.bat (718 Bytes)

Sorry for the bad news, but it didn’t work.

Might it be an error from my file?
I uploaded them below again for your kind review.

Many thanks in advance

Hey @Mohammad.ElGhandour ,

Ok, we’re still almost there. The reason why your file is not running is because the folder into which you are writing the GeoJSON has a space in it:

And I realized that there’s another case that we have to catch in order to handle simulation folders like this. I’m working on a fix now but, in the meantime, you should be able to get it to run by using a _folder_ that does not have a space in it. Maybe just call it Energy instead of Energy files.

Also, I definitely wouldn’t use a model with 250 buildings for testing. Just get it to work with a few buildings first and then you can always scale it up. Trying to run 250 buildings off the bat is going to take a few hours unless you have a really powerful desktop with 20+ CPUs.

1 Like

FYI, I also just pushed a fix for the case that the GeoJSON/Simulation folder has a space in it:

So another way that you can solve this issue for yourself is to just run the LB Versioner again. With the new fix, I don’t have any issues simulating the first 3 buildings of your Model when the simulation folder has a space in the path:

I changed the folder name and it didn’t work unfortunately, but I’ll now create a new windows profile

Hi @Mohammad.ElGhandour
I am having exactly the same issue as you. I have removed UrbanOpt 0.8.0 and installed 0.8.2 but I still cant run a simulation.

Did you eventually sort out this problem? Please let me know. Thanks!

Hi @ibitscholar ,

There is no released version of URBANopt that currently supports spaces in the username. Granted, I know NREL just made the fix in their code base so URBANopt 0.8.3 should be able to work for you. But, for now, you will need to make sure that you overwrite the env_uo.bat as we did here if you want to get tit to work without creating a new username.

Sorry for the late response.

I created a new user profile, I found Rhino installed but not ladybug so I installed ladybug tools again.

First I clicked run it gave me the same old message that it is not executable, then I copied these two files from my first user folder to the new one

After that I clicked run again, it gave me a new message.
Screenshot 2022-09-02 173305

Is it a problem in the batch files I copied from my old user or I have to remove the 0.8.2 version and install the older one?
I think it should work now after the new user, but I just want to make sure from that step.

Looking forward to hearing from you,

Nice! That means URBANopt is pretty much working, @Mohammad.ElGhandour . You just need to update your version of Ladybug Tools by running the LB Versioner. After that, you should be able to use your 0.8.2 installation of URBANopt and you’ll be all set!

A post was split to a new topic: Download Failed with LB Versioner

A different error appeared but I am optimistic, I feel we are getting closer to the solution.

Kindly find the error screenshot attached

After that cmd screen, this message appeared in grasshopper

Hey @Mohammad.ElGhandour ,

That screenshot of the command prompt looks like everything is running as intended and URBANopt is starting to download all of the resources it needs to start running the simulation. Just let that command prompt stay open and the simulation will begin shortly.

Also bear in mind that the sample file will simulate relatively quickly on a powerful desktop with 16 CPUs but it can take up to an hour on a standard laptop.

Many thanks for your consideration and sorry for the inconvenience.

It just happened again when I ran it. To state it clearly I made a screen recording for the process.
Kindly find it in the link below.

Thanks @Mohammad.ElGhandour ,

That video is very helpful as I could pause it at just the right moment to show you the real error at the bottom of the command prompt here:

You are experiencing the same issue that was reported here and has already been fixed in the latest development version of Dragonfly that is available with the LB Versioner:

Essentially, it’s a major limitation of URBANopt that it cannot use simulation folder paths, which are longer than 60 characters on Windows. So, if you’re looking for a quicker fix that doesn’t involve upgrading to the latest development version of Ladybug Tools, then just use a shorter path for your simulation folder (eg. C:\simulation).

Its flying … vizzzzzz

I made sure its the latest version and it didn’t work unless I followed your advice. It worked only when I shortened the path of the file. Oh, I am feeling so happy now, Many thanks for this very long journey and sorry for the inconvenience caused.

I want to mark the solution to close the discussion, but I don’t know which one to mark as it was a process. What is your advise?

Thanks again for your kind help and consideration.

1 Like

Glad that you finally got it to work, @Mohammad.ElGhandour .

Yes, there were a few different issues that we had to work through here.

I’m fairly confident that, after the new release of URBANopt, people should be able to simulate things seamlessly even when there are spaces in the username. So I’m not sure if this is really critical to mark as a solution for posterity.

However, NREL has informed me that they don’t know of any way to get around this long file path limitation on Windows. You might have seen that the latest development version of Dragonfly gives a clear error message about this and this is what I meant by saying it’s “addressed.” But it’s clearly just a band-aid solution and I’m sure that others will want to know about this issue.

In any event, we can mark this one as the solution since it gives a summary of all the issues you encountered here.

1 Like

Just to let you know I have tried to follow the solutions provided above, update URBANopt, run ladybug versioner etc, but i still cannot run with my username with a space.