Annual daylight 1.3 example error

I tried to run the Annual daylight example from LBT 1.3 instalation folder but the following error occurred - Solution exception:Input “sensor-count” was not found for recipe “annual_daylight”

Andris

It looks like you updated your core libraries to the latest development version of the plugin but you did not sync your Grasshopper definition with your installation. Run the LB Sync Grasshopper File component.

Thanks @chris!
The problem is solved.

1 Like

Hi Chris,

I see that now radiance appears to be dividing the total number of points by the selected number of workers again, instead of creating multiple smaller calculation grids with a default of sensor count of 200, which was the standard new approach since ladybug tools were revamped.

I loved that approach, as it greatly increased the simulation speed, so I’m sad to see it gone. Any reason why the sensor count optional parameter has been removed in 1.3.1?

Hi @pmcmm, You should still be able to set the cpu_count which does takes care of splitting the sensor grids behind the scene.

Yes, you can still set the number of workers on the recipe settings like so:

@mostapha , setting the _workers_ in the LBT Grasshopper plugin automatically sets the cpu_count that you’re referring to.

The default number of workers in the LBT Grasshopper plugin is always equal to use one less than the total number of processors available on your machine. That is, unless dividing up the sensor grids would result in less than 200 sensors per grid, at which point the overhead of grid-splitting should outweigh the performance benefit of further splitting.

Altogether, the even-splitting of grids with default workers set to one less than your machine’s limit should result in a significant performance boost from the older recipes. This is particularly true for simulations that previously took longer than a minute to run, for which we found speed improvements of 20%-50% (depending on the variation of sensor grid sizes in the model). If you find a case where the previous setup gave you better performance than the current one, then let us know and I’ll make sure the defaults of that recipe are set up give you better performance than you did previously. The only case where the performance of the current setup might be slightly worse is if the simulation takes under a minute to run, in which case I’d say that we’re splitting hairs and, if you need to run a study that is optimized for such a small model and coarse Radiance parameters, then there are other ways to do it rather than running a scalable recipe.

A post was split to a new topic: How do I add Sensor Grids to a Model?