Annual Daylight _ Results are not correct

Hi @mikkel

I am testing annual daylight on a project and have made a HBJSON model.
The model is validated and there are no errors.

Please find below the HBJSON Model and the log file.

logs.log (279.5 KB)

VDF_PC_Origin.hbjson (382.2 KB)

The simulation ran properly without any issues. When visualizing the results, I am getting no light in most of the rooms. Its an office building with glazing all around. I don’t know what the issue is.

Can someone point me to the right direction in what might be wrong.
I know that the definition is correct, since i tested it on a different model and it works fine.


To continue the discussion, looking at these post here and here regarding the air boundaries creating issues with Annual daylight studies, I ran the Daylight Factor study as well to understand the situation.
I am getting similar issues with the Daylight Factor results as well.

DF_logs.log (80.1 KB)

Please Advice.



An update to the above.
I ran the same model on the pollination annual daylight recipe and this is the result.

I am wondering if the lbt-gh uses different recipes than the pollination ones. In this example, it was quite an apparent issue since the office had a complete glass façade. I am wondering if some of the previous simulations that I have done using lbt-gh recipes are also wrong.

When i study the results folder created by both the strategies, the pollination gives the .ill files like how we had earlier. On the other hand, lbt-gh gives .npy files.

What do you suggest should be done so that we can get .ill files as an output for the lbt-gh workflow?


Hi @anujm1ttal,

It seems like the sensor grids are not offset from the floor surfaces in Grasshopper, but they are on Pollination. Can you check if that is the case?

The recipes are only different in the way they are structured and the format of the results folder.

1 Like

Hi @mikkel,

Thanks for pointing me to the right direction.
I realized while checking that my rhino tolerance and distance from floor, both were set at 0.1.
Hence the issue. Now, it works well.

Thanks again