Annualdaylight failing

I am trying to run a daylight simulation but it fails at one point
( - 1 failed - PrepareMultiphase(…))

I have absolutely no idea whats going on, any help would be appreceated.

My setup:

I have had a similar experience - my previously working annual daylight calculation fails with this error

2024-06-07 10:54:20 ERROR: “CalculateAnnualMetrics” failed. See below for more information:
FileNotFoundError: File C:\Users\TEMPUSERNAME\AppData\Local\Temp\CalculateAnnualMetrics-f5n0fcs8\raw_results_static_apertures_\default\total\N_00_03_2B3P_Bedroom_4cbb9a94.npy not found in the results folder.

It looks like the calculation has run but it is failing in the data analysis at the end. I solved it by turning the enhanced method off (not ideal) - it feels like a bug though as I don’t think I changed anything.

EDIT - I’ve also come across this error

  1. Solution exception:
    The recipe failed to run with the following error(s):

Execution Summary
Scheduled 38 tasks of which:

  • 17 ran successfully:
    • 1 CreateDirectSky(…)
    • 1 CreateRadFolder(…)
    • 1 CreateSkyDome(…)
    • 1 CreateTotalSky(…)
    • 2 DirectSky(…)
  • 2 failed:
    • 2 _TwoPhaseRayTracing_ae79e661Orchestrator(…)
  • 19 were left pending, among these:
    • 6 were missing external dependencies:
      • 1 CalculateTwoPhaseMatrix(…)
      • 1 CalculateTwoPhaseMatrixLoop(…)
      • 1 RunTwoPhaseDaylightCoefficient(…)
      • 1 TwoPhaseRaytracing(…)
      • 2 TwoPhaseRaytracingLoop(…)
    • 7 had missing dependencies:
      • 1 AnnualMetricsPostprocess(…)
      • 1 LetAnnualDaylightEnhancedFly(…)
      • 1 RestructureDirectSunlightResults(…)
      • 1 RestructureTotalResults(…)
      • 1 _Main_7efbbeb4Orchestrator(…)
    • 6 was not granted run permission by the scheduler:
      • 1 CalculateTwoPhaseMatrix(…)
      • 1 CalculateTwoPhaseMatrixLoop(…)
      • 1 RunTwoPhaseDaylightCoefficient(…)
      • 1 TwoPhaseRaytracing(…)
      • 2 TwoPhaseRaytracingLoop(…)

This progress looks :frowning: because there were failed tasks

I wonder if this error is related to the enhanced calculation method - it seems to reference the two phase ray tracing process

Ok., looks like it could be an issue with using an old version of Radiance - see this topic Annual daylighting cannot ran successfully

I tried updating Radiance to the latest version, also tried to change the Radiance Parameter detail level to both 1 and 2. I still get the same error.

According to the HB version checker it also runs the latest version:

Hi @Falk and @Will,

Please share your log files. You can find it here or in a similar path:



Here you go :slight_smile:
logs.log (92.6 KB)

Hi @Falk,

In the recipe input _thresholds_ you added “300”. You must use one of the valid keys, which you can see if you hover over _thresholds_ on the component. You can use e.g. “-t 300” which is also the default for daylight autonomy so there really is no reason to do that.


Its a partial problem, it works if i “detache” the ‘300’ panel and my occupancy file.

If I reattache my occupancy/ csv file it fails again, I have tried with different files and different type of files, I have attached the latest I tried with, and log file.
logs.log (84.4 KB)

StandardBR18_SunlitHours_Sun_is_up_utf8_semicol.csv (124.6 KB)

Hi @Falk,

The Daysim occupancy file does not work with the new LBT plug-in. You can get started with the data collection in the attached file. It will convert your CSV into a valid schedule. If you want to create a valid CSV you should just have one value per row, for daylighting either 0 or 1 (occupied). (16.5 KB)

1 Like

Hi @mikkel

Thank you. :slight_smile:

Trying to comprehend…

The annualDaylight component asks for a CSV containing 8760 rows of 0 or 1, one value for each row? (So the component already knows date and time according to the row?)
Using your script to collect values from csv and using the data output in the simulation works fine.
I have stripped my csv file from everything except the 0 and 1’s. so it now has 8760 rows of either 0 or 1, but it still fails.

0_1_8760_schedule.csv (25.7 KB)

Hi @Falk,

Yes, that is correct.

Change the encoding to UTF-8. You can do this with e.g. Notepad++. This file works for me: 0_1_8760_schedule.csv (25.7 KB)

1 Like

Hi @mikkel

Thank you very much, I saved as utf8 through excel though, did not check wether it was correct, just assumed it was. It was not.

Works like a charm now.