BRTDfunc and radiance error "truncated octree"

I used Optics to get the Radiance material definition for an insulated glass unit and I exported it to a rad file. The rad file has the following:

void  glass       RefliteArcticBlue6mm_glass
3     0.160     0.179     0.131

void  BRTDfunc    RefliteArcticBlue6mm_front
      0.555     0.561     0.478
      0.147     0.164     0.120
      0 0 0
9 0 0 0 0 0 0 0 0 0

void  BRTDfunc    RefliteArcticBlue6mm_back
      0.121     0.236     0.275
      0.147     0.164     0.120
      0 0 0
9 0 0 0 0 0 0 0 0 0

I have a basic setup to test glare and reflections in an urban canyon, and I tested the workflow multiple times with basic materials, it works fine.

But as soon as I replaced one of the materials with a material that has the BRTDfunc I got this error rpict: fatal - (glaretest_IMG.oct): truncated octree.

Here is what I changed (that led to the error), instead of having one surface for the window I modeled two surfaces, I assigned the exterior one the RefliteArcticBlue6mm_front material (direction facing outside), and the interior one RefliteArcticBlue6mm_back (direction facing inside).
BTW: I added both materials manually to the HoneybeeRadMaterials.mat file.

1 Like

I wonder if our parser fails to parse the material correctly. Can you check the project folder and see if the materials are exported as expected.

Yes, I guess that was it.
Here is the material file material_glaretest.rad (1.1 KB)

@mostapha, should I create a custom material using the way you described in this post?

That will only work for Honeybee[+] not Honeybee.

The best solution is to update the parser. Let me update it in Honeybee and then you can use the updated version. Does that work for you?

Yes, sure! No rush.
I can also try to work on the parser myself and see if I can modify it to work with the BRTDfunc material, although I won’t be able to start doing this until Monday.

Thanks for figuring out the problem!

@RaniaLabib, This should fix your issue:

@mostapha, impressive and speedy response. Thank you so much!

I replaced the and Honeybee_Honeybee.ghuser manually, this didn’t fix the issue, I’m replacing the right file?

Please note: syncing with GitHub doesn’t work for me, I get an error message about SSL/TLS certificate. I don’t mind updating and replacing files manually.


It looks like you’re replacing the right files, but you have some out-of-date honeybee files that may be contributing to the error.

To get rid of the SSl/TLS certificate error, you can download the ZIP file from mostapha’s git repo, and manually add all the .ghuser objects to the Grasshopper user object directory. Then your update honeybee object should work, and hopefully, the discussed error.

What @SaeranVasanthakumar said or you can use this file on Hydra to update your installation. It already has a fix for downloading issues.

Also once you replace the component you need to recompute the Grasshopper definition.

@SaeranVasanthakumar @mostapha, I tried both suggestions then I recomputed the definition. I’m not sure if the error message in the image is related to the problem. Could you take a look?

By the way, the file from Hydra fixed my syncing problem :smiley:

@RaniaLabib, Can you upload your custom radiance material file so I can replicate the error?

@mostapha, here is the file.
HoneybeeRadMaterials.mat (2.7 KB)
Just a quick note, even though I have the error message shown in the image, the simulations run fine, but I still get the “rcpict- Fatal error” whenever I use a BRTDfunc material. As a work around I write .bat files only then replace the BRTDfunc manually in the poject’s mat file, then run the simulations by running the .bat files.


Thanks! This was an edge case. I think I got it right this time.

@mostapha, I synced to Github and now the I don’t get the error message that is shown in the image I previously posted. The parser works perfectly, I looked at the project’s material file and all the materials seem to be parsed correctly. However, image-based simulations broke, regardless of the type of materials I’m using. I get the error in the image.
Although an HDR file gets produced, it’s corrupted (List of files in the image below)
Here is the error log error.log (478 Bytes)

The error happens before running rpict. Can you add a pause to the end of glaretest_IMGInit.bat and run it manually to see the error message?

I added a pause, and the error reads rpict: fatal - (glaretest_IMG.oct): truncated octree. But I figured out what happened; the parser repeated the last line of some of the materials. I guess i missed that when I looked at the project’s material file last night.
Here is the project’s material file that is created by HB material_glaretest_2.rad (1.2 KB)

1 Like

Hi @RaniaLabib, Thanks for figuring the issue and sharing the file. This one should be easier to fix. I’m surprised that I didn’t get the error on my side. I’ll take a closer look as soon as I get a chance.

Let’s see if “third time’s a charm”!

Impressive! This works like a charm :wink: Thank you so much, I really appreciate it!